OK doesn't close the cache pref dialog (JS Error: value.match is not a function)

VERIFIED FIXED

Status

SeaMonkey
Preferences
--
minor
VERIFIED FIXED
14 years ago
14 years ago

People

(Reporter: Isaac Hwak Han, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Regression between 20040131 and 20040205.

1. Edit => Pref
2. Advanced => Cache
3. Click OK

Error: value.match is not a function
Source File: chrome://communicator/content/pref/nsPrefWindow.js
Line: 245
Is |value| null there or something?  This looks like a regression from bug 63117

Comment 2

14 years ago
Well, I don't seem to get this error with the steps described in the tree where
the patch was derived from. (Win2k, in case this matters)
I'm just rebuilding current cvs and will report if anything changes there.

I also don't see how
- value = parseInt(value);                              
+ value = parseInt(value, 10);
would provoke this. Even when value is null, they seem to behave the same.

Uhh.... lxr says that the wrong patch (the second one) seems to have been
checked in. I'm telling biesi to take care of this.
the right patch is now checked in. marking fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Updated

14 years ago
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.