Saving file whose name contains # trashes the # and any characters following it

VERIFIED DUPLICATE of bug 180161

Status

Core Graveyard
File Handling
VERIFIED DUPLICATE of bug 180161
14 years ago
a year ago

People

(Reporter: Björn Wiberg, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

Saving an image with a filename containing a "#" character, the "#" and any
parts following it disappear in the "Save Image" file dialog.

The file extension is correct, though (that bug seems to have been fixed now).

Reproducible: Always
Steps to Reproduce:
1. View page with picture whose name contains # followed by some more
character(s), for instance, "fe14#001.jpg".
2. Right-click on the picture, choose "Save Image As...".


Actual Results:  
The "Save Image" file dialog pops up, and suggests an incorrect filename,
"fe14.jpg".

Expected Results:  
Suggested the filename "fe14#001.jpg"

I've turned on the "show file extensions" option for Windows Explorer, so that I
always see the file extensions in Windows Explorer and its dialogs. But that
shouldn't affect anything.
(Reporter)

Updated

14 years ago
Summary: Saving file containing # trashes the # and any characters following it → Saving file whose name contains # trashes the # and any characters following it

Comment 1

14 years ago
http://groups.msn.com/_Secure/0UADbApMYNNx95utwICJ4VZ5tXq5YZvxITwM7z5MjKcoT8l5PGDizy1rIc!oId2LisNnHligKis9caf8TRA13yrqR9qJnmsX70Y3I*uPzUDh2coX5xvMMhBQ1*QEAcPgo/fe14

The filename doesn't have a # in it. I'm sure you could read an rfc about it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
vrfy
Status: RESOLVED → VERIFIED
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---
See dup for clearer explanation.  Basically, the site is relying on a
URI-parsing bug in IE..

*** This bug has been marked as a duplicate of 180161 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.