missing "block/unblock cokies from this site" menu item (same thing for popups)

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
15 years ago
12 years ago

People

(Reporter: daniel, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

I would like to have a "unblock cokies from this site" menu-item (resp "block"
if cookies where unblocked previously). Similar for Popups. Also "open cookie
manager" ("open popup-manager" respectively) would be nice.

Mozilla had those in the tools menu (i think), and i really came to like it. 

Reproducible: Always
Steps to Reproduce:
look at the menu

Actual Results:  
If i visite a site (using firebird) that doesn't work because cookies (resp.
popups) are bocked, i have to go to
tools->options->privacy->cookies->exceptions, look for the site and change the
status. VERY inconvenient. 

Expected Results:  
I would like to have a "unblock cokies from this site" (resp. "unblock popups")
item in the tools menu, and/or in the page-context-menu. It would also be an
option to integrate site-specific popup/cookie/image-settings etc into the
Page-Info dialog.

In Moz this used to be one click (ok, two with opening the menu). I WANT THAT
BACK! becaus other than that, i like Firebird better ('cause it's smaller,
faster and nicer. thank you very much...)
please file individual issues as individual bugs.

The UI in question was removed and I don't expect it to be restored ever.  I
actually was the one who rewrote it for Mozilla, but I don't think it has a
place in Firebird.  http://basic.mozillanews.org has a toolbar button extension
that gives you access to this functionality for cookies.

regarding popup blocking, as it defaults to off, you can just use the statusbar
icon on unblock desired sites.  No menuitem is required.

I'm actually pretty sure this is a dupe of one or two or three different bugs,
just marking WONTFIX since all of those were marked like that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.