This URL causes Firebird to crash. I have Load Images for the originating website only turned on.

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Ken Gordon, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031026 Firebird/0.7

This URL causes Firebird to crash. It starts to load, gets to a certain point
(which I cannot identify), then crashes. If I stop the page loading early on, it
does not crash. I have "Load Images for the originating website only" turned on
(if that is important).

Reproducible: Always
Steps to Reproduce:
1.Go to www.globeandmail.com
2.
3.

Actual Results:  
Starts to load, then crashes. 

Expected Results:  
Should have loaded the page without crashing.

Comment 1

14 years ago
Can you try a recent nightly build? I can't reproduce the crash on Linux with
Mozilla 1.6.
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Can you try a recent nightly build? I can't reproduce the crash on Linux with
> Mozilla 1.6.

I downloaded mozilla-mac-MachO.dmg.gz dated 06-Feb-2004 11:51 and installed it,
but it will not run - the app starts to fire up, then unexpectedly quits.

I can confirm that with Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.5) Gecko/20031026 Firebird/0.7, if I select "load images" in the Firebird
prefs, but deselect "for the originating web site only", then Firebird does not
crash at the globeandmail.com site.
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > Can you try a recent nightly build? I can't reproduce the crash on Linux with
> > Mozilla 1.6.
> 
> I downloaded mozilla-mac-MachO.dmg.gz dated 06-Feb-2004 11:51 and installed it,
> but it will not run - the app starts to fire up, then unexpectedly quits.
> 
> I can confirm that with Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
> rv:1.5) Gecko/20031026 Firebird/0.7, if I select "load images" in the Firebird
> prefs, but deselect "for the originating web site only", then Firebird does not
> crash at the globeandmail.com site.

BTW, I am also running Adblock (v 0.5 d2 Nightly Build 35). I'll see if that
might be causing the crash.

Comment 4

14 years ago
Page loads fine on Gecko/20040121 & adblock 0.5.2 build 34

Comment 5

14 years ago
The page seems to load without crashing for me (20040205 Firebird/0.8.0+), even
with "Load images for the originating website only" selected.

Kevin, could you please temporarily trash your user prefs (basically the entire
Phoenix folder in the Library in your home folder), restart the browser, set the
image preference again, and see if the page still crashes? A lot of obscure
crashes seem to be the result of corrupt user prefs.

cheers

Comment 6

14 years ago
Er, I meant Ken, not Kevin. Sorry about that :)
(Reporter)

Comment 7

14 years ago
(In reply to comment #6)
> Er, I meant Ken, not Kevin. Sorry about that :)

No problem. I won't be back at that machine until Tuesday, and will try then. 
(Reporter)

Comment 8

14 years ago
By the way, Wayne, do  you have Adblock running? On Friday I began to conclude that the problem 
was there and not with Load Images. But I did not have time to try the various perms and combs to 
confirm my suspicion. 

Comment 9

14 years ago
Page loads fine on
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ja-JP; rv:1.7a) Gecko/20040206
Firebird/0.8.0+
Mozilla Firebird extention has not installed.
The default theme is used.
Mac OS X 10.3.2

Comment 10

14 years ago
No, I don't use adblock, or any Firebird extensions.

Comment 11

14 years ago
WFM,
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7a) Gecko/20040210
Firebird/0.8.0+
I think that this page has Flash, so it may be a Flash plugin problem
(Reporter)

Comment 12

14 years ago
I am now convinced it's an Adblock problem, and will move to the appropriate
discussion.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.