Error starting Firefox on virgin Windows 95 (A) system: MSVCRT.DLL not found

RESOLVED WONTFIX

Status

()

Firefox
General
--
major
RESOLVED WONTFIX
14 years ago
12 years ago

People

(Reporter: Glen Richards, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Error dialog: Error Starting Program, A required .DLL file, MSVCRT.DLL was not
found.

This error occured after a clean install of Windows 95 (A).  The first thing I
did after installing was connect to the web with IE 1.0! & download Firebird.

I was able to resolve this problem by installing Symantec Norton System Works
2000 on my computer - this must have placed MSVCRT.DLL onto my PC.

Reproducible: Always
Steps to Reproduce:
1. Install Windows 95 (A) from CD onto a blank HDD
2. Boot the system, & copy the latest Firebird onto the HDD
3. Run Firebird - the error message should appear.

Actual Results:  
Error Message as described.

Expected Results:  
Firebird to load normally.

Updated

14 years ago
Severity: minor → major
Can you test this with Firefox 0.8, the update to Firebird 0.7?  If it's still
there we might be able to do something, and if it isn't there's no bug.  In any
case, a bug for an old milestone isn't particularly likely to get much attention.

Actually, this might be a problem with old DLL files, as I take another look. 
Can you run Windows Update and see if it has any updates to msvcrt.dll, too? 
That might be the problem.
Summary: Error starting Firebird on virgin Windows 95 (A) system: MSVCRT.DLL not found → Error starting Firefox on virgin Windows 95 (A) system: MSVCRT.DLL not found
Forgot to mention: if you could try Firefox 0.8 with a clean profile that would
be great.  Your profile is probably in
C:\Windows\Profiles\<username>\Application Data\Phoenix, although I could be
wrong.  The location changed between Win95 and XP, and I've only got XP.
(Reporter)

Comment 3

14 years ago
Even though I can reproduce this, it would mean a complete re-install of my OS 
on my PC.  I'll see what I can do.

Ironicly, to run Windows Update, you need IE... but I'll give it a try :)

This bug is extemly minor in my point of view - as I easily found a work around 
(in my case installing another app - that had the required file).

I'll do some research into msvcrt.dll as well.
(Reporter)

Comment 4

14 years ago
Hi, I finally got round to trying to reproduce this bug using FireFox 0.8.  I 
installed Win95(A) clean & then downloaded Firefix 0.8 & tried to install it.  
This time it crashed with an invalid page fault in COMCTL32.DLL while trying to 
install.

My guess is that this is a new bug caused by the new installation routine that 
came with FireFox 0.8 for Windows.

Can I download a windows version of FireFox 0.8 that is similar to 0.7 in 
installation (ie no setup program)?  I'll check it out & if find one, download 
& try it out.

Does any of this info help?  Let me know if there is anything else I can do.  
Thanks.
(Reporter)

Comment 6

14 years ago
I downloaded the zip version of FireFox 0.8 & tried running it.  I got the same error as in 0.7: MSVCRT.DLL was not found.&#013;&#013;So we have 2 bugs here, the first is the MSVCRT.DLL issue & the other is the GPL when trying to run the 0.8 installer - does someone want to create a new bug for the GPL or should I do it?&#013;&#013;The GPL bug occurs after it tries to "verify the integrity of the archives" - or something like that.&#013;&#013;Remember that these issues occur on a clean Win95A system with no IE (except for version 1 of IE that came by default with Win95A).&#013;&#013;I've had little time to do any research into what MSVCRT.DLL is - I think it's got something to do with monitors.

Comment 7

14 years ago
Hi!
I got some information about msvcrt.dll.

At first it hasn't to do anything with screens. It's the Microsoft C Libary 
wich contains standard C functions such as printf, cos etc.
It has been shipped for the first time with MS Visual C++ 5.0.

You can download it from several places on the net (for example 
http://dll.softandco.com/dll/3/Msvcrt.dll.html)

As it seems that this bug is only caused on abscebce of this particular libary, 
I think we should offer a link to that (or a similar) page where Win 95 users 
can download it.

How about that?

Philipp
I'm not sure we're even going to support 95 in the system requirements.  Even
the current page lists 98 as the earliest.
QA Contact: mconnor

Comment 9

14 years ago
I'm pretty sure that Win95 is not going to be supported -> invalid?
(Reporter)

Comment 10

14 years ago
Firefox seemed to run fine on Win 95 except for the install issue - which seems
to be just a missing dll file.  Thus I rekon this "bug" would be easy to fix.

But all that been said - I've accepted the fact that Win 95 is now obsolete - a
lot of new software these days just won't support it.

So feel free to resolve this bug as "Won't Fix".  Or am I supposed to do that? -
since I opened the bug.

Cheers.

Comment 11

14 years ago
To the best of my knowledge, i think even Microsoft have stopped support for
Windows 95. As such, it is pretty tough on Mozilla to expect them to!

marking : wontfix.

More info on MS Product Lifecycles :
http://support.microsoft.com/default.aspx?id=fh;[ln];lifeprodw
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
We haven't officially killed off support for win95 yet, but when we do we can
WONTFIX this.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 13

14 years ago
Same problem with Mozilla 1.7.2 on a freshly installed Windows 95. Windows 95 is
a supported platform according to
http://www.mozilla.org/products/mozilla1.x/sysreq.html so this is a bug.

Comment 14

13 years ago
Here are my experiences with Firefox (and Thunderbird, for that matter) on
WIndows 95A. The version I used before Firefox 1.0 came around was, if I recall
correctly, Firefox 0.9 and Thunderbird 0.8. I had no problems running or
installing these.
Some time later I had to reinstall Windows and then I tried to install Firefox
1.0 and Thunderbird 1.0 on a clean system. The self-extracting .exe files with
official builds failed to run. I only saw a dialog box with a progress bar and
when progress reached 100%, the dialog disappeared without any error messages or
any information that could help me. So, I downloaded both birds as zip archives
and extracted those. Both firefox.exe and thunderbird.exe failed to run -
nothing happened after I double-clicked the exe files and again there was no
error message  nor any other information about what happened and why things
didn't work.
But then, I restored my profile directories (c:\windows\Mozilla and
c:\Windows\Thunderbird) from backup and - to my surprise - both Firefox and
Thunderbird work now. This is quite strange, as these directories contain only
data (as far as I know) and no DLL's or other binaries. Perhaps some sort of
DLL's or other system resources not available on a clean Win95A install is only
necessary to generate the default profile data and is not used any more once
profile directories are in place?

Comment 15

13 years ago
The official system requirements at:

http://www.mozilla.org/products/firefox/system-requirements.html

list only Win98 onward.  I think this one should be marked WONTFIX.  Anyone got
the privs to do that?
WONTFIX.  At the least, 95B or later is going to be needed for some things.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.