If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Losing Local Folders Solution

RESOLVED FIXED in Thunderbird0.8

Status

Thunderbird
Preferences
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: Tom Peterson, Assigned: Bienvenu)

Tracking

({fixed-aviary1.0})

unspecified
Thunderbird0.8
Other
Windows XP
fixed-aviary1.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: 

I am posting this here as I can figure out how to submit to an FAQ so...

We discovered a similar problem early in Netscape 7.x and expect this may be a 
holdover. 

Verify that the “Local Directory” of the Server settings is NOT the same 
storage location as “Local Directory” of the Local Folders setting. This 
causes that exact problem of losing folders. 

The “Local Directory” of the Server location is used to build index (.msf) 
files for folders on the server and as these files need to be possibly rebuilt 
every time you connect to the server they can be deleted each time you exit 
the software. So, if the software settings are pointing to the same location 
as your “Local Directory” of the Local Folders (your really stored email 
folders) this has a very undesired affect. When you exit the software the 
folders are deleted anticipating rebuilding them when you start up again. It 
only happens to those folders that are actually opened during the session and 
they appear (and are) normal until at the point you exit the software, 
unfortunately when you re-launch they are subsequently missing. 

We found this by setting all the local folder files to have read-only 
attributes and then saw an error message when we exited the software because 
the delete would fail. 

I feel the software should be changed to not permit a configuration where both 
these values are allow to be the same storage location.   Also, I’d suggest 
the phrasing of “Local Directory” of the Server location be change to 
say, “Local Area for Server Indexing” and phrasing of “Local Directory” of the 
Local Folders be change to say, “Locally Stored Email Directory”.  We point 
the “Local Directory” of the Local Folders to a much nicer place on the user’s 
hard disk to simplify having the user backup their emails.  There is just too 
much junk in the c:\documents and setting…. area (cache for one) that doesn’t 
need backed up.

Tom.Peterson@uni.edu
Director, ITS User Services
University of Northern Iowa
(319) 273-6460


Reproducible: Always
Steps to Reproduce:
1.Backup local email folders so you don't lose anything
2.Set both Local Folders to actual stored email folders location 
3.exit and re-launch email
4.open an email folder
5.exit the software and re-launch
6.the email folder you access will likely have disappeared

Actual Results:  
loss of email as folder file was deleted.

Expected Results:  
see explanation above.

This is a holdover problem that we identified in Netscape 7.0 and appears to
still exist today.  I posted here as I saw a Mozillazine request for help and
got positive feedback this cured the problem for another user too.  He stated 
this should be added to FAQs and fixed, I agreed.

Comment 1

14 years ago
yes only bad things can happen if you point two folders to store their mail in
exactly the same directory. Tom, are you actually deploying Thunderbird at UNI
or you just have a couple users that were using it and tried to do this? 
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Thunderbird0.6

Comment 2

14 years ago
I won't get to this before 0.6 is released.
Target Milestone: Thunderbird0.6 → Thunderbird0.7

Updated

14 years ago
Target Milestone: Thunderbird0.7 → Thunderbird0.8
(Assignee)

Comment 3

13 years ago
taking - I have lots of dups of this, but we should really prevent users from
doing this in tbird 1.0 - will try to get to it by .8
Assignee: mscott → bienvenu
Status: ASSIGNED → NEW
(Assignee)

Comment 4

13 years ago
Created attachment 155170 [details] [diff] [review]
proposed fix

this prevents you from setting the local directory for a server to the same
directory as any other server, at least through the UI. The user can still edit
their prefs.js by hand, and users that have already messed up their directories
will still be messed up, but we may not have time to address that.
(Assignee)

Updated

13 years ago
Attachment #155170 - Flags: superreview?(mscott)

Comment 5

13 years ago
Comment on attachment 155170 [details] [diff] [review]
proposed fix

should we lose the dump statements before checking in?

Thanks for fixing this.
Attachment #155170 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 6

13 years ago
dumps removed before checking in to trunk and branch.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.