Support custom glyph substitutions in mozTXTToHTMLConv

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
20 years ago
3 years ago

People

(Reporter: BenB, Unassigned)

Tracking

({helpwanted})

Trunk
helpwanted
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Smilies etc are hardcoded at the moment. Need to add prefs to add/delete/chnage
them.

The plan is to use JS regexps for that. Maybe create a JS module and read prefs
and exec regexps from there or (worse) hardcode them in JS.
(Reporter)

Updated

20 years ago
Status: NEW → ASSIGNED
Priority: P3 → P4
Target Milestone: M15
(Reporter)

Updated

19 years ago
Target Milestone: M15 → M20
(Reporter)

Comment 1

19 years ago
Shaver said, this change would also improve performance. Maybe we can prove that
by feeding rginda's converter with several MBs of data at once.

This bug has several parts:
1. Creating a JS module, which converts chunks of text of arbitary length by
handing then to the JS regexp object. It also has to read prefs to know its
regexps.
2. Invoking the JS module from mozTXTToHTMLConv.
3. Resolve the escaping issues this bug arrises in mozTXTToHTMLConv (other
converter parts need unescaped input.)

Due to my lacking JS knowledge, I can't implement 1.
(Reporter)

Comment 2

19 years ago
HELP WANTED (maybe I'll "help myself" some time :-) )
Assignee: mozilla → nobody
Status: ASSIGNED → NEW
Keywords: helpwanted
(Reporter)

Updated

19 years ago
Target Milestone: M20 → Future
(Reporter)

Updated

19 years ago
Blocks: 42017

Comment 3

18 years ago
*** Bug 66653 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

18 years ago
Depends on: 48179

Comment 4

18 years ago
mass move, v2.
qa to me.
QA Contact: tever → benc
(Reporter)

Updated

17 years ago
Blocks: 116842
Priority: P4 → --
Target Milestone: Future → ---
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.