Last Comment Bug 233417 - Reply options: Ability to reply ToSender or ToList
: Reply options: Ability to reply ToSender or ToList
Status: RESOLVED WONTFIX
:
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: unspecified
: All All
: -- enhancement with 25 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 288501 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-08 07:05 PST by Biju
Modified: 2009-06-16 10:28 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Biju 2004-02-08 07:05:19 PST
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040131 Firebird/0.8.0+

Some maillist dont modify "Reply-To:" to point back to them 
If thunderbird could give an option it will be a great help

Following are usual headers
  From:
  Reply-To:
  List-Post:
  Mail-Followup-To:

Following logic can get ToSender, or ToList address
ToSender = From:
ToList = List-Post:

if(!ToList) if(From: <> Reply-To:) ToList = Reply-To:
if(!ToList) if(From: <> Mail-Followup-To:) ToList = Mail-Followup-To:



Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Mike Hommey [:glandium] 2004-02-17 23:14:36 PST
(I'd add that the Reply-to: header on MLs is harmful and should not be there)

Anyway, I'd also add it would be nice to have Reply-to sender/list/whatever
buttons in the toolbar as well (not necessarily enabled by default)
Comment 2 Tobias Sager 2004-07-16 03:37:59 PDT
Duplicate of Bug 45715?
Comment 3 Zak Kipling 2004-11-02 03:04:37 PST
Yep, looks like one.
Comment 4 Biju 2004-11-19 00:08:58 PST
(In reply to comment #2)
> Duplicate of Bug 45715?

NO, slightly different this is for mails from EZMLM, Mailman etc.
http://directory.google.com/Top/Computers/Software/Internet/Servers/Mail/List_Management/
like http://cygwin.com/ml/cygwin/2004-11/msg00746.html

The mail also have header "List-Post:" 
I want mail client to completley ignore emailid in "To:" and "From:" of recieved
mail and use only the id in "List-Post:" of  recieved mail as "To:" of reply mail

Bug# 45715 talks about converting "CC:" in incomming message as "To:" for
outgoing message.
Comment 5 Greg 2005-04-01 06:03:05 PST
*** Bug 288501 has been marked as a duplicate of this bug. ***
Comment 6 Tim Riker 2005-04-06 12:53:18 PDT
Might want to have a Reply-To: dropdown someplace that grabs:

From:
Reply-To:
List-Post:
Mail-Followup-To:
Sender:
Return-path:
List-Id:

and populates a list. Any URLs that are found in the msg headers should be made
links when all headers are visible.
Comment 7 S. Zachariah Sprackett 2005-06-26 08:24:06 PDT
(In reply to comment #6)
> Might want to have a Reply-To: dropdown someplace that grabs:
> 
> From:
> Reply-To:
> List-Post:
> Mail-Followup-To:
> Sender:
> Return-path:
> List-Id:
> 
> and populates a list. Any URLs that are found in the msg headers should be made
> links when all headers are visible.
Comment 8 Komka Peter 2006-11-01 04:34:38 PST
A "Reply-to-To" would (>90%) solve the "great maillist replying misery".

And, a "Reply-to-From" would solve (~) the rest.

explanation:
MLs place the list addrecc in the 'To' field.
It is okay, as this place was "free", as in rare cases I want reply to myself.
Then, the list address was (tended to) placed in the 'Reply-to' field as well. In order to "direct the Reply to the right place (the list)".
They forgot that it makes the (valid!) 'From' address unavailable. One cannot reply to a mail! Neither "Reply" or "Reply-to-All" command will give other address than the list address.
Comment 9 Scott 2006-11-02 01:09:19 PST
This is pretty standard stuff in any number of MUAs (Kmail, Evolution, Sylpheed, Pine, Mutt....).

I've never understood why Mozilla overlooked it.

Please, by all means, add this feature yesterday.
Comment 10 Mike Cowperthwaite 2007-01-26 16:55:28 PST
(In reply to comment #4)
> (In reply to comment #2)
> > Duplicate of Bug 45715?
> 
> NO [...]
> I want mail client to completley ignore emailid in "To:" and "From:" of
> recieved mail and use only the id in "List-Post:" of  recieved mail as 
> "To:" of reply mail

That's what the patch at bug 45715 implemented -- but only for List-Post; there's no support for Mail-Followup-To as described in the original report.
Comment 11 Rimas Kudelis 2009-06-01 14:28:49 PDT
This has been solved in Bug 45715.

*** This bug has been marked as a duplicate of bug 45715 ***
Comment 12 Tim Riker 2009-06-01 15:56:13 PDT
This but is NOT just a duplicate of 45715 as explained in the comments above.

Are we to understand that the patch in 45715 adds a "reply" option to all of these choices:

To:
From:
Reply-To:
List-Post:
Mail-Followup-To:
List-Id:
Sender:
Return-path:

If all those are present, than calling this a duplicate is fine. If just List-Post: was added, then that's NOT all that's needed. IMHO reply should have a dropdown with each of these things listed. I'm happy to have that drop down hidden unless you pick "power user reply drop down" or some similar from the menu.

The From: and To: headers let you right click and pick "Compose Mail To" from the list, then "quote" the message. This is nice, but it screws up threading on lists or in user's in boxes as the message is NOT marked as a reply.

One should be able to "reply" to each of those addresses.

Please re-open or confirm that all the requested functionality has indeed been added.
Comment 13 Rimas Kudelis 2009-06-01 16:20:32 PDT
OK. But I suggest to change the misleading title of this bug because what you just listed doesn't really look like the same request made in the title. Basically you're asking Tb to implement replying to an email mentioned in any header whatsoever, and honestly I don't think this would happen.

OTOH, you may want to file a new bug suggesting what other headers to look for when replying to list. E.g., if list-post not found, look for list-id, and if that not found, look for mail-followup-to (BTW, I've never heard of such header until now) and so on. I really don't think there's a point in presenting user with 20 reply options. Instead, existing ones (now that Reply to List is there) should be improved.
Comment 14 Bryan Clark (DevTools PM) [@clarkbw] 2009-06-01 16:50:21 PDT
if you read bug 45715 comment #155 we intend to offer a "reasonable" set of options to choose from, annotating what they are.

I don't think we'd include the option for every possible posting for every message.  If that's what you want it's likely that you could use the existing code to rework the reply button to include all the options.  Also I don't think that we'd accept a preference to toggle 'power user options' vs. 'reasonable options'.

I can definitely help create an extension that provides this behavior. bug 391272 comment 41 has some quick instructions to get started

Likely you'll just offer a modified version of the UpdateReplyButtons() function that does something like this:

for (var header in your_header_options) {
  if ( currentHeaderData[header] ) {
    addReplyMenuItem(currentHeaderData[header]);
  }
}

You can check out Martin's code on bitbucket to see what he did, the approach is very similar.
Comment 15 Ludovic Hirlimann [:Usul] 2009-06-01 21:54:59 PDT
Based on Bryan's comment - WONTFIX - this should be implemented as an extension

Note You need to log in before you can comment on or make changes to this bug.