All users were logged out of Bugzilla on October 13th, 2018

memory lost in mozilla(mozrmi36.dll).

RESOLVED DUPLICATE of bug 233258

Status

--
critical
RESOLVED DUPLICATE of bug 233258
15 years ago
8 years ago

People

(Reporter: deepakpj, Unassigned)

Tracking

Trunk
x86
Other

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: All the mozilla open source releases.

         Memory loss in Mozilla(mozrmi36.dll). The problem occurs when an 
object is evaluated with javascript. At every call to the routine (approx every 
second) an additional memory object   is allocated,after about an hour the 
system failed. When the class file is running in the java environment, it uses 
the setJavaScriptVariables()function every second.
           The problem is that the IWB is allocating constantly memory.We can 
see this with "Private Object Summery for 'OS2WEB'" or  with the "Memory leak 
detection for Process"View. In this   we can see that MOZRMI36 will allocate 
constantly memory.
           Memory leak is occuring on all the mozilla open source releases for 
OS/2 and windows.

Reproducible: Always
Steps to Reproduce:
1. Run the memory leak detection tool
2. Run mozilla
3. Connect to 9.155.32.101
4.Click on the first link on the page(secure link)
5. Accept Certificate (OK)
6.Accept wrong domain(OK).
7.Login using as BenuterID: “testuser” and password as Kennwort: “test”.
8. Press “Anmelden” button.
9. Select mozilla process from memory leak detection tool.
10 select Memory leak detection.
11.Set the time interval for 10sec for log update.
13.Start Periodic Update


Actual Results:  
Memory for mozrmi36.dll is getting allocated approximately every second 
constantly. After about an hour the browser gets terminated.

Expected Results:  
Every time the memory allocates for mozrmi36.dll, it has to deallocate the 
memory after job is done.

 From our code analysis and testing by  putting log statements, found-
     TheGetWindow(..) which is called periodically and would be
responsible for memory  allocation.In this routine,"handle" is declaired
locally, which is a pointer to JSObectHandle structure.Then allocation done
for JSObjectHandle and assigning the address of the  allocated memory to
this "handle".Assigns integer value of the address of the handle to the
*pobj which is a input param to the GetWindow routine(proj is of type
jsobject, a typedef  of jint). Here pobj is a pointer to the jsobject(that
is jint). We can't free the handle,since it is could be used by some other
function.If we try to free the handle explicitly, we will get a trap.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 233258 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

8 years ago
Component: Java: Live Connect → Java: Live Connect
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.