Firefox credits chews up 100% CPU and looks jerky

RESOLVED WORKSFORME

Status

()

Firefox
General
--
minor
RESOLVED WORKSFORME
14 years ago
5 years ago

People

(Reporter: Anders Kaseorg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

On Firefox 0.8 Linux+GTK2, the credits screen in the about box chews up nearly
100% CPU (between firefox-bin and X). That makes it look very jerky because the
kernel is forced to interrupt it often. The framerate needs to be limited to
something sane.

Some smaller about bugs: there's a scroll bar on the build ID box that moves it
up or down by one pixel, and the credits screen still has the old icon and says
"Insert Motto Here!".

Reproducible: Always
Steps to Reproduce:
1. Help, About Mozilla Firefox
2. Click Credits

Actual Results:  
CPU-sucking, jerky scrolling.

Expected Results:  
Framerate should be limited.

Comment 1

14 years ago
Adittionaly, the text displaying the contributers should be justified.

Comment 2

14 years ago
Behaves the same on Windows NT:

Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
(Reporter)

Updated

14 years ago
OS: Linux → All

Comment 3

14 years ago
Created attachment 141725 [details]
Proposed Motto fro Firefox 'Credits' window - see Comment

Suggestion for the missing Firefox 'Motto' in the 'About Firefox' - [Credits]
button:

Motto: 'GO and GET it'

'Rationale': Te basic function of a browser it to GET information from the
Internet / Intranet / Extranets / Etc. This proposed Motto tells Firefox to 'GO
and GET it.
(Reporter)

Comment 4

14 years ago
Re: comment 3
Firefox already has a motto: "The Browser, Reloaded." We don't need a new one,
and IMHO, your proposal is pretty weak anyway (sorry).
*** Bug 240066 has been marked as a duplicate of this bug. ***
Confirming this Bug on Mac OS X.
As the reporter of Bug 240066 (now dupe of this one), I wrote:
-----------
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.7b) Gecko/20040408 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.7b) Gecko/20040408 Firefox/0.8.0+

When you open the credits dialog, as soon as the scrolling of the names start,
CPU load is 100%.
It goes back to normal once the dialog is closed.

Reproducible: Always
Steps to Reproduce:
1.open the credits dialog
2.wait for the scrolling to begin
3.watch your CPU getting fried ;-)



Expected Results:  
use reasonable CPU time

Comment 7

14 years ago
can't reproduce the problem here:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040527
Firefox/0.8.0+
with AMD Athlon-XP 2.2 GHz
when viewing the credits CPU usage for firefox is less that one percent, never
goes into double digits even for a second.

maybe it has something to do with graphic drivers..
Still the same behaviour here on MacOS X.3.4 using my latest trunk nighty
(Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a2) Gecko/20040530
Firefox/0.8.0+ (MMx))
The scrolling is nice and smooth, but my CPU is a 100% and the fan speeds up
like crazy.

Confirming bug and changing "Hardware" to "All" because it occurs on Macintosh also.
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: firefox.general
Hardware: PC → All

Comment 9

14 years ago
It's pretty smooth here (though it takes 100% CPU) until it gets to the big wad
of text at the end, then it scrolls at about a fifth of the original speed. :)
That's on Linux, athlon750.  CPU time is split between around 65% firefox, 35% X.

Comment 10

14 years ago
*** Bug 233872 has been marked as a duplicate of this bug. ***

Comment 11

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I also get 100% cpu utilization (but smooth scrolling) on Win XP Pro 1Ghz, with
firefox.exe taking up at least 93% of the cpu time.

Comment 12

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

I don't get anything near 100%. varies between 20-30%

Comment 13

12 years ago
This doesn't happen any more for me with the (last 3 or so) latest versions.  The interface can sometimes be a bit sluggish, though, taking a while to react to a click - not so much on a link on a page, but on a back button, or reload, etc, ie: interface elements.
(Reporter)

Comment 14

12 years ago
Sorry, I still see the problem (Firefox 1.5 on Linux). It looks like nothing has changed. (To those reporting 20-30% CPU usage, remember that the graphics driver is doing the majority of the work. Besides, 20% is still ridiculous.) How hard can it be to limit the framerate? We don't need the credits scrolling by at 500 FPS.

Comment 15

11 years ago
WFM, 0-1% CPU, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061128 Minefield/3.0a1
Severity: normal → minor

Comment 16

11 years ago
(In reply to comment #15)
> WFM, 0-1% CPU, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1)
> Gecko/20061128 Minefield/3.0a1

That's on XP. Reports of this problem have been on Linux and NT.

Still does *not* WFM on NT:
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1 ID:2006120418

100% CPU usage while credits scroll and occasional pauses in the scrolling.
Assignee: bross2 → nobody

Comment 17

11 years ago
WFM now in the trunk. 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007070520 Minefield/3.0a7pre ID:2007070520 [cairo]
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
That is, again, Win XP. Problems have mostly been reported with Linux, MacOS X and Win NT4 though.
Reopening for now, until somebody can say "WFM" on the other platforms, too.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 19

11 years ago
(In reply to comment #18)
> That is, again, Win XP. Problems have mostly been reported with Linux, MacOS X
> and Win NT4 though.
> Reopening for now, until somebody can say "WFM" on the other platforms, too.

Martin, do you see this on OSX? 

Comment 20

10 years ago
WFM!

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1pre) Gecko/2008070106 GranParadiso/3.0.1pre
old bug and this is wfm
Please file a new bug in case that this still happens
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.