form elements aren't focused on OSX: select drop downs and checkbox, radio, image, and submit

RESOLVED DUPLICATE of bug 170833

Status

RESOLVED DUPLICATE of bug 170833
15 years ago
14 years ago

People

(Reporter: rishi, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Molliza 1.6 

When you hit tab (or shift-tab) on most forms elements, the focus goes to the
next (or previous) element in the form. However, this doesn't work for select
form elements or input elements of types checkbox, radio, image, reset, or submit

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.dbi.tju.edu/~rishi/bugzilla/form_bug.html
2. Tab over the different elements
3. Note that certain form elements don't get focused (they do in IE for OSX)
4. See http://www.ftls.org/en/tutorial/HTML/index9.shtml for examples of all
form elements and how mozilla behaves on them.
Actual Results:  
same as above

Expected Results:  
Each form element should get focus as it is tabbed over
This is purposeful -- by default, tabbing tabs through text boxes only on OSX
(since that behavior is what mac users apparently expected).

There is a preference in the "Keyboard Navigation" section of preferences to
change this behavior.

*** This bug has been marked as a duplicate of 170833 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: form elements aren't focused on OSX: select drop downs and checkbox, radio, image, and submit → form elements aren't focused on OSX: select drop downs and checkbox, radio, image, and submit
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.