Closed Bug 233534 Opened 17 years ago Closed 17 years ago

Firefox unpacked the .gz file without asking me

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 233047

People

(Reporter: u49640, Assigned: bugs)

References

()

Details

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

I've downloaded the current Thunderbird from the url above. Firefox 0.8 saved
the file as thunderbird-0.5-macosx.dmg.gz on my Harddisk, but it was allready
unpacked!
I really dont want this to happen. i've downloaded the gz file and it should
stay that way until i unpack it.
Or at least change the extention, when its no longer a .gz File
For some reason the Windows version of thunderbird wasnt unpacked, maybe because
its in a .zip and not a .gz
If firebird supports unpacking .gz Files it should ask me if i want it

Reproducible: Always
Steps to Reproduce:
1. Download the .gz File
2. Its unpacked


Actual Results:  
The .gz File was unpacked

Expected Results:  
It should stay as it was. I want Firefox to download the Files not doing
something with them
the resulting thunderbird-0.5-macosx.dmg.gz on my harddisk isnt a .gz file
anymore (deleting the ".gz" made it usable under MacOs as Disk Image)
I can confirm this behaviour.
BTW, it happens only with gzipped files, .bz2 and .zip aren't affected.
This problem is associated with Apache webservers being configured with:
"Content-Encoding: gzip"

However, this still amounts to a valid complaint wherein if the browser is going
to support decompression on the fly like this, it should give the user a choice
as to whether they want to decompress the file, or change the filename to
reflect the decompression has taken place.

*** This bug has been marked as a duplicate of 233047 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
QA Contact: aebrahim
Resolution: --- → DUPLICATE
Summary: Firefox unpacked the Zip file without asking me → Firefox unpacked the .gz file without asking me
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.