this.blur() causes Mozilla 1.6 to hang, crash

RESOLVED DUPLICATE of bug 232368

Status

()

Core
Event Handling
--
critical
RESOLVED DUPLICATE of bug 232368
14 years ago
14 years ago

People

(Reporter: mgueury, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Reproducibility
---------------
No   Mozilla 1.5  Windows    
No   Mozilla 1.5  Linux
Yes  Mozilla 1.6  Linux
Yes  Mozilla 1.6  Windows
Yes  Firefox 0.8  Windows


Reproducible: Always
Steps to Reproduce:
Testcase
--------
1) Copy/Paste the following HTML in a file (bug.html)

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <title>Bug Mozilla 1.6</title>
</head>
<body>

<form action="xxx" method="post" name="bugform">
  <input type="text" name="status" size="3" maxlength="2" value="10">
  <input type="text" name="status_desc" size="26" maxlength="30"
    value="blur"  onfocus="this.blur()">
</form>
</body>
</html>

2) Open the file with Mozilla 1.6/Firefox 0.8
3) You are in the first field.
   Type a value ex:'12' and press tab.
4) Mozilla/Firefox hangs.
5) You need to kill the process
Created attachment 140974 [details]
reporter's testcase

In the future, it's better to attach testcases rather than pasting them in bug
comments.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 232368 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.