"Save link to disk..." file picker doesn't have "all file types (*.*)" option

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: tok, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

when trying to download any of the files linked from this site, i only get the
file type option 'text', while with earlier builds i had the chance to cosse
'all file types' or sth like that

Reproducible: Always
Steps to Reproduce:
1. go to the site above
2. right-click on any of the links (text files with sgf-extension)
3. choose 'save link to disk'



Expected Results:  
firefox should have given me at least the option 'all file types' which would
allow me to view the contents of the directory and save it as expected ...
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
> Gecko/20040206 Firefox/0.8

Firefox has forked the download UI code.  Please don't file bugs on it on Mozilla.
Assignee: general → bugs
Component: Browser-General → Downloading
Product: Browser → Firefox
Version: Trunk → unspecified

Updated

15 years ago
Summary: download procedure severely limited → "Save link to disk..." file picker doesn't have "all file types (*.*)" option

Comment 2

14 years ago
While it doesn't explicitly say all file types (*.*), this is what it shows in
the case of where there is an extension it doesn't know what to do with. The
file still gets saved as blah.sgf, and the save as window shows all the files in
the folder.

Isn't this what you're asking for? If so, please resolve the bug with resolution
invalid.
Severity: major → normal
QA Contact: general → aebrahim
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
> While it doesn't explicitly say all file types (*.*), this is what it shows in
> the case of where there is an extension it doesn't know what to do with. The
> file still gets saved as blah.sgf, and the save as window shows all the files in
> the folder.
> 
> Isn't this what you're asking for? If so, please resolve the bug with resolution
> invalid.

no, this is obviously not, what i'm looking for. the 'save as'-dialog doesn't
make that much sense, if i'm not able to rename a file with a correct extension.
Severity: normal → major

Comment 4

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040302
Firefox/0.8.0+

WFM. While it does not ask what type to save as it does save with the correct
file extension.
(Reporter)

Comment 5

14 years ago
in that case, i want to be able to *see* the files of the respective type in the
folder, which allows me to use a consistent naming of the files. so, clicking on
an older file, and then adjusting the name is not possible. (in addition: if i
remember correctly, this problem didn't exist in the previous beta)

Comment 6

14 years ago
--> NEW
--> normal

SeaMoneky allows the user to select All Files as an option. Firefox should do
the same.

Current Firefox behaviour for .sgf files:
Save as type box is blank, and there is no option to change it to anything

Current Firefox behaviour for .pdf files:
Save as type box shows Adobe Acrobat File, and no option to change it to anything

SeaMonkey behaviour:
Save as file box minimally shows two things:
1) (File type) .foo
2) All files

Option 1 (default) filters by that extension, whereas option 2 doesn't filter at
all.

Saving behaviour should be as follows, assuming download has extention foo (on
server):
+ Save as type box shows .foo
  - File name chosen is blah, saved as blah.foo
  - File name chosen is blah.bar, saved as blah.bar.foo
+ Save as type box shows All files
  - File name chosen is blah, saved as blah.foo
  - File name chosen is blah.bar, saved as blah.bar

This mirrors the SeaMonkey behaviour, and is I think the best thing for Firefox
to do too.
Severity: major → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 7

14 years ago
bug not resolved in 0.9 ...
Using FF 1.0/Linux
This is an embarrassing bug to still have in 1.0 - especially when the file to
be saved is e.g. some control file of mome type text/plain that contains text
but has some extension xxx. FF only allows to show a couple of extensions that
seem to be common to be text files on Windows which are useless in this situation. 

The dialog will in that case not even show *other* files with that extension
xxx. And there is no way to simply show all files because the "All (*.*)" filter
is not in the drop down list. No mather what heuristics FF uses to show other
filters, the "All" filter should always be available. 
OS: Windows XP → All

Updated

12 years ago
QA Contact: ali → download.manager
Assignee: bugs → nobody
WORKSFORME
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b5pre) Gecko/2008031104 Minefield/3.0b5pre
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.