If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The javascript used in "Sort Category By" does not work; gives an object not defined error.

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: Michael Friesen, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

The Nordstrom.com site uses javascript functions to Sort Category By: What's
New, Price, Brand, Bestsellers.  Clicking on the link, which calls a javascript
function, throws the following error:
Error: frmProductFinder is not defined
Source File:
javascript:frmProductFinder.sort.value='-price';frmProductFinder.submit();
Line: 1
Every version of Mozilla that I have used, on Mac OS X, Windows, and Linux all
fail.  This function works in IE, Safari, and Konqueror.

Reproducible: Always
Steps to Reproduce:
1.Click on a link for either "What;s New", "Price", "Brand", or "Bestsellers"
next to "Sort Category By:" 
2. Nothing appears to happen, but an error is thrown in the Javascript Console.
3.

Actual Results:  
Nothing happens

Expected Results:  
The page should reload with the items re-sorted.
> Error: frmProductFinder is not defined

That's because in IE window.foo === document.getElementById("foo").

I'm sorry to hear that Konqueror has knuckled under and implemented the same
misfeature; Mozilla has no plans to do that.
Assignee: general → english-us
Component: DOM: Level 0 → English US
Product: Browser → Tech Evangelism
QA Contact: ian → english-us
Version: Trunk → unspecified

Comment 2

10 years ago
Works in Camino trunk and Firefox 2 now. FIXED by redesign.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.