Collected Adresses Book not being populated

VERIFIED FIXED in M14

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
major
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: esther, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Reporter)

Description

19 years ago
Using builds 20000106 on win98, mac and linux addresses are no longer being sent
to the Collected Addresses address book. Not sure when this broke, but it was
working.  On all 3 platforms, selecting a message the From address does not go
to the Collected.  With win98 and linux a To: recipient does not go to the
Collected Address Book.  Still checking Mac.

1. launch Messenger
2. Open the Address Book from the Tasks menu
3. Open your Collected address book and either delete all cards or just one card
that you know you have a message from in your Inbox.  Close Abook
4. In Messenger, Select a message from a person whose card you removed from the
Collected Address Book.
5. Open Address book again and view cards in Collected Abook.

Expected: N new card listed for the person whose message you just opened.
Result:A new card listed for the person whose message you just opened.
(Reporter)

Updated

19 years ago
Summary: [DOGFOOD]Collected Adresses not being populated → [DOGFOOD]Collected Adresses Book not being populated
(Reporter)

Comment 1

19 years ago
Correction:
Result should read "N0 new card listed for the person whose message you just
opened."
Expected should read "A new card should be listed for the person whose message
you just opened."

Comment 2

19 years ago
We'd really like to see this for M13, but it's not dogfood.
Whiteboard: [PDT-]

Comment 3

19 years ago
Collection address book is on the beta 1 "in" list so it should be functional.
(Reporter)

Comment 4

19 years ago
Using 2000011909m13 mozilla build on Mac this is still a bug.

Updated

19 years ago
Target Milestone: M14

Comment 5

19 years ago
Marking M14. cc bienvenu. David is this your bug?

Comment 6

19 years ago
My guess would be that I'm not getting called anymore because of the new message
display stuff.
(Assignee)

Updated

19 years ago
Assignee: chuang → mscott
(Assignee)

Comment 7

19 years ago
This is my bug. I didn't think anyone would notice =) and I never got around to
filing a bug to go back and fix it later.

Re-assigning to me assuming candic doesn't object.

Comment 8

19 years ago
Release Notes for M13.

Comment 9

19 years ago
Collected addresses has to work for beta1.
Keywords: beta1

Updated

19 years ago
QA Contact: lchiang → esther
(Assignee)

Comment 10

19 years ago
I didn't see much in the way of apis for adding an address / full name pair to
an address book. The closest thing we have now is the nsIAbAddressCollector
interface which adds an email address. But it adds it to a hard coded address
book (the history AB) which is the wrong one.

We may want to bring up a partially filled address book card if the user selects
add to address book. If we do that, Paul can I bring up an AB card without bein
inside the address book xul framework?

Comment 11

19 years ago
Putting dogfood in the keyword field.
Keywords: dogfood

Comment 12

19 years ago
the history ab is the collected addresses - it's not the wrong one.

Comment 13

19 years ago
Here's the code that used to do the trick:

nsresult
nsMimeXULEmitter::DoSpecialSenderProcessing(const char *field, const char 
*value)
{
	nsresult rv = NS_OK;
	if (!nsCRT::strcmp(field, "From"))
	{
		NS_WITH_SERVICE(nsIAbAddressCollecter, addressCollecter,
						kCAddressCollecter, &rv);
		if (NS_SUCCEEDED(rv) && addressCollecter)
			addressCollecter->CollectAddress(value);
	}
	return rv;
}
(Assignee)

Comment 14

19 years ago
David, forgive me. this comment went in the wrong bug. My comment about not
having the right API was intended for add sender to address book not collected
address books.

=)

Comment 15

19 years ago
yes, I wondered about that :-)

Comment 16

19 years ago
Clearing PDT- resolution for reconsideration.  One of the items on the beta1 
list is to have the collected address book functional.  If this is not the case 
and this bug gets the PDT- designation again, we should not advertise this 
feature then.
Whiteboard: [PDT-]

Comment 17

19 years ago
When this feature was working, I showed it to several folks who loved it. I 
would really like to have this feature for beta1.
(Assignee)

Comment 18

19 years ago
Sol, I will definetly have this checked in for beta. It's only 3 or 4 lines of
javascript at the most.

Comment 19

19 years ago
Putting on PDT- radar for beta1.  But do check this in.  Would not hold beta.
Whiteboard: [PDT-]

Updated

19 years ago
Summary: [DOGFOOD]Collected Adresses Book not being populated → Collected Adresses Book not being populated
(Assignee)

Comment 20

19 years ago
In an effort to keep my promise to Sol, I just checked this in. We are now
populating the collected address book again with email addresses in the From field.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 21

19 years ago
Scott - thank you!!! I really appreciate this.

Comment 22

19 years ago
Anyhow, I have in my mind, that addresses are only supposed to be collected on a
reply, not on read. I like the reply version better, because it prevents my
collected address book from being littered with spammer addresses and other
addresses, in which I'm not interested.

Is there a way to achieve the described functionality, e.g. via a pref?

(I know, that I can disable this feature completely, but that's not, what I
want.)

Comment 23

19 years ago
Yes, we plan to allow finer granularity of which addresses get collected in a
later milestone.
(Reporter)

Comment 24

19 years ago
Using build 2000-02-24 -09on Win and Linux and -08 on mac this is fixed.  
Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.