Don't lose all prefs after encountering one broken pref

RESOLVED DUPLICATE of bug 107264

Status

()

RESOLVED DUPLICATE of bug 107264
15 years ago
15 years ago

People

(Reporter: csthomas, Assigned: csthomas)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

In bug #98533, Brendan Eich said:
else error, ignore this line (if not the whole file?).

and Darin Fisher said:
"i'm actually making PREF_ParseBuf return PR_FALSE if any syntax error is
discovered.  i like this better than just discarding the rest of the current
line since a pref function call might actually span several lines.  recovering
from syntax errors is a rats nest i'd prefer to avoid."

I don't think it should be too difficult to at least attempt to continue parsing
- I think I'll give it a shot.  It would annoy me a lot to lose half of my prefs
because of one error.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 107264 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.