Page begins to display, then unexpectedly closes on multiple PC's with different OS's, repeatable.

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Sam, Unassigned)

Tracking

({qawanted})

Trunk
x86
All
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

When Visiting the web-site http://www.starsofdavid.org, It is reported that
after clicking on the tribute card icon to the left you arrive at this
page:http://www.starsofdavid.org/tributecardintro.html,
Then when using the "click" button on this page to attempt to Java Open via "#"
this page: http://starsofdavid.org/tributecard_orderform.html - The browser
unexpectedly closes.

This has been tested on a Windows 98PC, and a newer Windows XP Pro PC - Both of
which CAN load this fine using IE6, however both experience the same unexpected
window closure when using the Mozilla Browser.

This does appear to be a "Java" problem as both pages properly load if the
correct URL is typed directly into the browser, however the Pop open does crash
when the "Click" is pressed.  - Did look for the bug, Did not find.  Did check
the "popup block" feature was disabled while attempting to load this.

The code was inspected, and appears to be correct for the page.

Please address / advise.  Best regards, 

Sam - Webmaster - www.starsofdavid.org


Reproducible: Always
Steps to Reproduce:
1. go to http://www.starsofdavid.org
2. Click on the tribute card icon on the left column of the page
3. Near the bottom of the page content, just above the blue bar, in this line
"To order one or more Stars of David Tribute Cards, please click to open the
Tribute Card order form." - Click the "Click".
4. Observe the problem


Actual Results:  
The page began to load in a new window, then unexpectedly closed the new window.

Expected Results:  
The page should have been displayed.

Bug reported to me by a viewer / staff.

This repeats on my system as well as the system reported on... This is a long
time used form and path, without any other browser type complaints - We track
browser usage and receive IE/Netscape/AOL Traffic mainly.

I am using a P4 Hyperthreading 2.6GHZ machine with 1gig DDR and MS XP Pro
software fully updated - Desert Solutions Developer White Box.

This originally reported to me as a bug from a site viwer using a 450MHZ Win98
Machine with the following info:

- Browser type - Version, Revision:
    Mozilla v. 1.6b  (problem NOT experienced with Internet Explorer v.
6.0.2800.1106)
- Operating system:
    Windows 98
- PC Hardware Build / Brand:
    Intel P-III 450 MHz, 384MB memory, unbranded
- Site path: (How did the get to the page, or how they were trying to get to the
page)
    typed in www.starsofdavid.org, then clicked on left-hand Tribute card icon.
 From Tribute Card page, clicked on "click here"
- Any error message, or description of what happened that was not expected.
    Order form started to open up and then immediately closed.  Reproducible. 
No error messages.


--
After an inspection of the site / page for code error, I proceded to look at the
mozilla pages for any duplicate or reccomends... I tried the popup block disable
and pipline not on things, but both were default off, thus not the cause for
this to repeat on my different build system.

The current workaround is bening installed for Mozilla users as a "Mozilla Users
Click Here" button on the page - untill this is responded to.

Thank You,

Sam
Keywords: qawanted
Summary: Page begins to display, then unexpectedly closes on multiple PC's with different OS's, repeatable. → Page begins to display, then unexpectedly closes on multiple PC's with different OS's, repeatable.

Comment 1

14 years ago
I see this on LInux 2004030609
This might be TE.  I notice that there is some code that can close the pop up
window, but I'm not a DOM expert.  
Thanks for a workaround for the mozilla users.
OS: Windows 98 → All
Product: Browser → Seamonkey

Comment 2

13 years ago
this is (or at least was) very much Tech Evang.

1. the JS sets an onbeforeunload handler to close the window, but also returns
true (don't ignore the link), which sends the browser to "#", which closes the
window.
2. the JS sets the window to close after a timeout.  That timeout is 1 second
but
3. they added an additional non-JS link to the page at the bottom (for Mozilla
users), which works fine, so this isn't really worth spending the time to do
tech evang.

Sam: if you want to tell them why the window closes unexpectedly, feel free to
do so.

but this bug has come to its end
resolving INVALID -- this is not a Mozilla bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.