If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Marking a message as "not junk" doesn't return it to original state

VERIFIED DUPLICATE of bug 208197

Status

MailNews Core
Filters
--
minor
VERIFIED DUPLICATE of bug 208197
14 years ago
9 years ago

People

(Reporter: Ian Beyer, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

When using Junk Mail Controls, messages determined to be Junk are placed in the
Junk folder. However, marking an erroneously tagged message as "Not Junk" does
not return the message from whence it came.

Reproducible: Always
Steps to Reproduce:
1. Mark a message in a folder as "Junk"
2. Message is moved to the Junk folder
3. Go to Junk folder and mark message as "Not Junk"


Actual Results:  
Unmarked message remains in Junk folder

Expected Results:  
Returned the message to the folder it was in when initially flagged as Junk.

Manually moving the message works fine, but sometimes it's unclear what folder
the message may have come from in the first place.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 208197 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.