filters based on relative date

RESOLVED DUPLICATE of bug 177294

Status

RESOLVED DUPLICATE of bug 177294
15 years ago
14 years ago

People

(Reporter: noo, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.0.1) Gecko/20030102

I'd really like to see an easy way to build advanced custom mail
filters like
"If a message has been in the 'junk' folder for more than a week ->
delete it"
Or that would remind me once a day to reply to msg in my unreplied
folder...

in general messages based on on the relative date (as opposed to the
absolute date "two days ago" or "one day since the last time" vs.
"12/4/2003" ) vould be very useful in my opinion.

Thunderbird is a great software and I love it, thanks to all the
people that are working on it.
Bye,

Michele

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Rule of "Age in Days"(= Today - ReceivedDate) "is/less than/greater than" N day
is already implemented although weeks/months/years/centuries etc. based
conditions are  not implemented yet.

Comment 2

15 years ago
Running on Mac OSX build 20040412, and I don't see the 'Age in Days' item in the
headers dropdown.

Comment 3

15 years ago
I hacked the msgFilterRules.dat file, and the rule works, but as I said there is
no UI for it at present. At least not in TB 20040412.

Comment 4

14 years ago
Reporters (Michele, Per Reedtz Thompson): the Age in Days filter is not 
implemented for IMAP, only for POP mail -- bug 177294.
Which account type are you using?

Comment 5

14 years ago
I use IMAP. Bug 177294 describes what I'm seeing.

Comment 6

14 years ago

*** This bug has been marked as a duplicate of 177294 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.