correctly installed italic fonts are not shown by mozilla

RESOLVED WONTFIX

Status

Core Graveyard
GFX: Gtk
RESOLVED WONTFIX
15 years ago
7 years ago

People

(Reporter: Klaus P. Kuhlemann, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [GTK1 only], URL)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

In the page www.traki.de/index.html the text in the first part (Tahoma +1 <i>)
is not shown in italic. This font is installed and correctly rendered by Opera
and Konqueror om the same SuSE 9.0 system. Preferences are set correctly.  

Reproducible: Always
Steps to Reproduce:
1.Open a page with a part designed for Tahoma, size "+1", <i>
2.The font is not shown italic.
3.

Actual Results:  
Wrong rendering of the Tahoma ttf.

Expected Results:  
Rendering the text italic as designed.

This is a Linux-specific bug shown by firefox 0.8 final and Mozilla 1.6 final
In Windows, the fonts are displayed correctly.

Comment 1

15 years ago
I can't make tahoma cursive either - but as it turns out, I don't have an italic
version of tahoma installed. Do you?

xlsfonts |grep tahoma
-microsoft-tahoma-bold-r-normal
-microsoft-tahoma-medium-r-normal

Only two regular versions of it here - medium and bold weight, from the MS
webfonts collection.
Summary: correctly installed italic fonts are not shown by mozilla → correctly installed italic fonts are not shown by mozilla
Assignee: nobody → blizzard
Component: Layout: Fonts and Text → GFX: Gtk
QA Contact: core.layout.fonts-and-text → ian
(Reporter)

Comment 2

15 years ago
RKAA - that is true, I installed my Tahoma, which was not in the Microsoft 
collection I got via Suse, setting a link to the .ttf-font installed in a
Windows system on the same machine. But you are right, even in this Windows
folder, there is no "Tahoma italic" file. So the Browser and other programs have
a feature to show fonts italic even if this is not installed like they do with
the size and the weight of the fonts when css is used. This seems to be broken
in Mozilla. In every other appplication without NS 4.8, Firefox and Mozilla 1.6,
I can use italic Tahoma, even in KWord and Konqueror. If this font would not be
installed, the browser should show one of the other fonts described in the
website: "Tahoma,Verdana,Arial,Helvetica". But it is clearly visible Tahoma.   
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 4

13 years ago
This is still present in latest seamonkey gtk1 - builds only, the (newer)
gtk2-build and firefox -even konqueror and Opera- render the italic fonts
correctly. I think that is a gtk1 problem only.
Inbetween I updated completly my linux system from suse 8.2 over 9.0 to suse 9.3 
and got every time this behaviour using a gtk1 build.. Could someone visit
www.traki.de with a gtk1 build to confirm?

 
Assignee: blizzard → nobody
QA Contact: ian → gtk
Whiteboard: [GTK1 only]
(Assignee)

Updated

10 years ago
Product: Core → Core Graveyard
Since we no longer support GTK1 in any way, closing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.