DOM Inspector's preferences menu not working

VERIFIED DUPLICATE of bug 225644

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 225644
15 years ago
12 years ago

People

(Reporter: gandalf, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
In Firefox 0.8 DOM Inspector's preferences menu is not working anymore.

Steps to reproduce:
1) Open Firefox
2) Go to DOM Inspector
3) Open Preferences
4) Try to change pane

Comment 1

15 years ago
Changing OS to all based off my test on Linux cvs build.  

When I try to effect a change, I get 

JavaScript error:
chrome://global/content/nsWidgetStateManager.js line 42:
this.pageData[aPageTag].elementIDs has no properties

same as I get when clicking on anything in the side panel
 
OS: Windows XP → All

Comment 2

15 years ago
Some more details:

The right side pane never changes from "Element Blinking" preferences. 

The left pane expand/contract items expand and contract as expected to reveal
sub-item choices

+ Appearance
+ Navigator
+ Privacy
+ Advanced

However, clicking on any of those items, or the revealed subitems doesnt change
the right side pane. 

Changing the Right side pane preferences allows you to change the GUI elements
on that pane (Selecting the checkboxes or changing the border color), but the OK
and HELP buttons dont do anything. Only the CANCEL button seems to function.



Using release build: 0.8

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Comment 3

15 years ago
*** Bug 236895 has been marked as a duplicate of this bug. ***
This menu item and also others are relics from SeaMonkey. The whole menu should
be updated till Firefox 1.0. I'll try to find or open a meta bug for all DOM
Inspector issues which should be solved.

-> QA
QA Contact: bugzilla

Comment 5

14 years ago
I made a patch to remove some menus and the broken Preferences from the DOM
Inspector, see bug 241079.
Depends on: 241079

Comment 6

14 years ago
Bug 241079 removed DOMi's broken preferences dialog in Firefox.

For the future, DOMi needs to register itself properly as an extension in
Firefox, like Chatzilla already does, and provide options like other extensions.
Bug 225644 is about that. Marking as duplicate of that bug.

*** This bug has been marked as a duplicate of 225644 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Updated

13 years ago
QA Contact: bugzilla → general
You need to log in before you can comment on or make changes to this bug.