[PP] Mac, Win - MODAL DIALOGS BROKEN

VERIFIED FIXED in M13

Status

MailNews Core
Networking
P3
blocker
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: cpratt, Assigned: dougt)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build ID: 2000010713
Platform: All

To reproduce:
- Launch mozilla
- Select Tasks | Mail
- Click the Get Msg button

Result:
The app never actually checks mail. You can't stop it, can't close the window,
can't quit the app; you have to force-quit the app instead. This is using a POP
server; it works okay on Linux using an earlier build.
(Reporter)

Updated

18 years ago
Summary: [PP] Mac OS - App can't check mail → [PP] Win32, Mac OS - App can't check mail
(Reporter)

Comment 1

18 years ago
This also seems to be a problem on Windows 98. Using Win 98, I can't ever
actually log into the POP server, but I can close the window and/or quit the
app. I can't Stop the logon process either.

Using the 2000010708 Linux build, mail worked okay for me with the same POP
server.

Comment 2

18 years ago
Apparently people who have this problem are those with remember password turned
off.

The mac is apparently hanging when we try to bring up the password dialog on
imap and pop. This bug isn't pop specific.

cpratt, can you confirm that you aren't using remember password on the accounts
that are failing for you? Thanks.

Updated

18 years ago
Summary: [PP] Win32, Mac OS - App can't check mail → [PP] Win32, Mac OS - App can't check mail --> MODAL DIALOGS BROKEN

Comment 3

18 years ago
cpratt, yell at us if we are incorretly changing the summary of this bug.

Paul's been playing around with this bug some more and it appears that modal
dialogs on the mac are broken in general. This includes the password dialog,
bringing up the new card in the address book window, etc.

Comment 4

18 years ago
dougt thinks this might be him.

Updated

18 years ago
Summary: [PP] Win32, Mac OS - App can't check mail --> MODAL DIALOGS BROKEN → [PP] Mac OS - App can't check mail --> MODAL DIALOGS BROKEN

Comment 5

18 years ago
The failure to read mail on windows that you reported in this bug was due to Bug
#23378 where dns look ups were failing.

To keep this bug focused on Mac modal dialogs, I'mgoing to remove win32 from the
summary line.

Updated

18 years ago
Assignee: mscott → dougt

Comment 6

18 years ago
Dougt is taking over this bug. Re-assigning to him. Thanks Doug.

An easy browser dialog to see the hang is open web location.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 7

18 years ago
my mac is dead, however, try this fix.  I am not sure it works.

RCS file: /cvsroot/mozilla/widget/src/mac/nsMacMessagePump.cpp,v
retrieving revision 1.88
diff -r1.88 nsMacMessagePump.cpp
271c271
< 	if (aRealEvent == PR_TRUE)
---
> 	if (aRealEvent == PR_TRUE && anEvent->what != nullEvent)

Comment 8

18 years ago
The change to:
if (aRealEvent == PR_TRUE && anEvent->what != nullEvent)
did not help.  Still hang.  :-(

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Target Milestone: M13

Comment 9

18 years ago
The current event queue needs to be fetched each time events are processed, rather than
reusing a cached queue. All better now.
(Reporter)

Updated

18 years ago
Summary: [PP] Mac OS - App can't check mail --> MODAL DIALOGS BROKEN → [PP] Mac, Win - MODAL DIALOGS BROKEN
(Reporter)

Comment 10

18 years ago
Seems to be broken in the 2000011008 Win32 build as well. I'm leaving this as
RESOLVED FIXED until I can be 100% sure of that though.

Comment 11

18 years ago
I don't see the problem with a (debug) build from this morning.

Comment 12

18 years ago
I don't see this problem with today's build, either. I'm going to reopen the
mozilla tree.

Comment 13

17 years ago
Linux (2000-08-25-08 M18)
Win32 (2000-08-25-08 M18)
Mac (2000-08-25-04 M18)
This bug should be closed. An old old bug that has been fixed
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.