If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash after printing with Schubert PDF plug-in [@ CopyRgn]

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Ben Fowler, Assigned: Blake Ross)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

After printing is complete, Firefox crashes. Not every time, but easily
reproducible - just under half the time. I am printing PDF files using the
Schubert Plugin.

Reproducible: Sometimes
Steps to Reproduce:
1. Open a link to a PDF file
2. Use the pop-up to select print
3. Click OK in dialog

Actual Results:  
The printing happens, but Firefox crashes

Expected Results:  
Should not crash

This is the standard Firefox download. It stops me from rolling out this product.
The Mac OS X version is 1.2.4, but the summary of this bug is very similar to
Bug 230754 (Panther). Crash report to follow.
(Reporter)

Comment 1

14 years ago
Created attachment 141143 [details]
Crash log from darwin

Log shows crases occuring with plugin v 1.2 and 1.2.3
(Reporter)

Comment 2

14 years ago
Created attachment 141303 [details]
Crash log for mozilla-bin

This bug does occur on the standard Mozilla release, but it is far
less frequent perhaps only 1 in 10 or 1 in 20 times as frequent as
in Firefox
I cannot reproduce the problem with MacOS X.3.3 and Schubert 2.0.1

Does this behavior still occur with the latest plugin version?

Updated

14 years ago
Severity: major → critical
Keywords: crash
Summary: Crash after printing with Schubert PDF plugin → Crash after printing with Schubert PDF plug-in [@ CopyRgn]
resolving WORKSFORME, if this can be replicated with the new version of the
plugin, please reopen
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

14 years ago
I don't have a set-up likely to evince this, at present; but given the
history, resolving WFM or 'not reproducible, seems the only thing
to do. This has never been seen with Schubert's plugin later than 1.2.3

Note that this does seem to indicate a weakness in either the Mac OS
or the Mozilla architecture. If the plug-in faults then the plug-in
process/thread should be killed and the parent process (Firefox) continue
and clean up.
For me Firefox Branch* crashes reproducibly trying to load this pdf (bug URL) with Schubert 2.1 
installed (also 
tested with 2.0.1, same effect). 

Talkback Incident ID: TB3225993Z.
It is the first crash after 1 Year of no problems with Schubert/PDF.

Boring details below (pointing to an OS/Memory-Management Problem... but FF shouldn't die, should 
it?).

- Apple Safari, Camino and Omnigroup Omniweb die as well, Safari even without Apple Feedback 
Agent. 
- The Apple PDF-Viewer Preview itself dies, trying to open File from Disk (Apple Feedback Agent this 
time). 
- Adobe Acrobat 6 (the editor, not the Reader) does not like this file either: It first warns me that an 
embedded TTF from the file could not be used. Than it tells me that I would need more memory 
(because the pdf would 
contain a large image) which is probably not true (1GB Ram) and refuses to open the pdf.
- Adobe Acrobat Reader 7 (Basic Version) finally displays the file, only telling me that the embedded 
TTF is unusable.

* Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de-DE; rv:1.7.5) Gecko/20041122 Firefox/1.0
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(In reply to comment #6)
> For me Firefox Branch* crashes reproducibly trying to load this pdf (bug URL)...

Sorry, just noticed that this bug is all about printing. Should I open a new one (Crash trying to load...?)

Comment 8

13 years ago
The PDF url above downloads fine but crashes Preview. It could very well be the
PDF file which is causing the printing problem.

Ben Fowler, Can you still reproduce this bug with a recent build and up-to-date
version of the Schubert plugin? If you can, please reopen this bug.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050309
Firefox/1.0+
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

13 years ago
No I can't reproduce. I am not actually using the Schubert Plugin on a 
production system at the moment, but I have not seen this since
April last year. I don't recall having tried with versions of the Plugin 
later than 1.2.3

This is probably WORKSFORME.
Crash Signature: [@ CopyRgn]
You need to log in before you can comment on or make changes to this bug.