[REGRESSION] All flavor data written to the clipboard, even if not asked for

VERIFIED FIXED in M13

Status

()

Core
XUL
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Mike Pinkerton (not reading bugmail), Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

18 years ago
Win32 seems to have developed this problem where it wants to write all flavors to
the clipboard, even before any of them are asked for. It should just advertise
that the flavor is there, but not put out until the data is explicitly requested.

This seems to be a regression, as i think this used to work. I can't test on
linux, i'm afraid. akk/pav, can you see if this is the case as well? Mac doesn't
have this problem as its Clipboard api's ride the short bus and always put all
data on the clipboard up front.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M13
(Assignee)

Comment 1

18 years ago
accepting, m13

Updated

18 years ago
QA Contact: paulmac → elig
(Assignee)

Updated

18 years ago
Whiteboard: fix in hand, waiting for tree.
(Assignee)

Comment 2

18 years ago
i found why this is happening on win32, it was in win32 code. I talked to pav and
linux never seemed to have this problem. waiting to check in a fix.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Whiteboard: fix in hand, waiting for tree.
(Assignee)

Comment 3

18 years ago
fixed.
(Assignee)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Comment 4

18 years ago
verified.

Comment 5

18 years ago
Thanks, Mr. Pinkerton!
You need to log in before you can comment on or make changes to this bug.