iframe designMode=on breaks all future redirects

VERIFIED DUPLICATE of bug 209020

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 209020
15 years ago
9 years ago

People

(Reporter: Mark Hobson, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When setting designMode=on for the content document of an iframe in the body
onLoad event, all future redirects do not work.  They continue to be ignored for
the lifetime of the browser and is only fixed by relaunching Firefox.

The attached files demonstrate this problem.

Reproducible: Always
Steps to Reproduce:
1. Open bug.html in Firefox
2. Click the 'Submit' link


Actual Results:  
The browser 'displays' the redirect page - the meta refresh can actually be seen
by viewing the source.

Expected Results:  
The browser should be redirected back to the original bug.html page.

N/A
(Reporter)

Comment 1

15 years ago
Created attachment 141146 [details]
A page to demonstrate the bug
(Reporter)

Comment 2

15 years ago
Created attachment 141147 [details]
Redirect page to supplement main page

Comment 3

15 years ago
Not Firefox-specific.
Assignee: firefox → general
Component: General → Browser-General
Product: Firefox → Browser
QA Contact: general
Version: unspecified → Trunk

*** This bug has been marked as a duplicate of 209020 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.