Closed Bug 233843 Opened 21 years ago Closed 21 years ago

application firefox quits while dowloading and installing extensions

Categories

(Toolkit :: Downloads API, defect)

PowerPC
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 233574

People

(Reporter: jklimantan, Assigned: bugs)

Details

(Keywords: crash)

Attachments

(2 files)

User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Firefox quits unexpectedly when trying to dowload and install an extension

Reproducible: Always
Steps to Reproduce:
1.on extension page click to dowload/install an extension
2.dowload begins
3.application quits

Actual Results:  
application quits and extension is not installed

Expected Results:  
install extension like in firebird

crash log result :
Component Manager: attempting to find symbols in a component alias of type
(regR/carP/x!bt)
## Component Manager: attempting to find symbols in a component alias of type
(regR/carP/x!bt)
dyld: /Applications/Firefox.app/Contents/MacOS/firefox-bin Undefined symbols:
/Applications/Firefox.app/Contents/MacOS/libxpcom.dylib undefined reference to
_wcrtomb expected to be defined in /usr/lib/libSystem.B.dylib

Occurs every time on my two ibooks (the two of them with 10.2.6) with firefox
(11/02/04). Worked fine with previous firebird (completely deleted) or mozilla...
Otherwise firefox works relatively good...
Confirming this bug using:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206
Firefox/0.8
Mac OS 10.2.8

For me, this is a blocker!
(In reply to comment #1)

With a little more time at my hands, I'll add some more information here:

I used the official mac Firefox0.8 release and tried to install various
extensions from the extensionroom. It is 100% reproducible for me.
The strangest thing is: It works fine on my own builds from the source tarball
and CVS (FIREFOX_0_8_RELEASE). These builds still have bug #204484, althought
that one is fixed in the official release. :-/
So what is the difference between the CVS/source tarball and the code used to
build the official build? (exept for the branding ;-) )

I'll also attach my crash log, it seems that the JS engine crashes. (Correct me
if I'm wrong).
Can confirm this on Mac OS X (10.2.8).

Using: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Tried to install the EditCSS extension 4 times. Crashed everytime. The 20040206
release creashed every time and left the extension in a download state of
"installing" in the download window.

I replaced the 20040206 official release with the latest nightly (20040211) and
it worked fine. I then deleted the newest nightly and replaced back with the
"older", "official release" and all is well, now.

Strange work-around.
Severity: minor → major
(In reply to comment #6)

I tried the following, just to double-check:
1. build a fresh FIREBIRD_0_8_BRANCH checkout
2. run that one - instlling extensions works just fine.
3. delete the prog, but leave the profile intact
4. unpack the official build and launch it - installing extensions fails. 
   (previously in-profile-installed extensions are availiable, of course.)
So much for a workaround . . . an easier workaround is not to use the official
build at all.

To sum it up: Installing extensions works in: 
1. build from source tarball
2. build from FIREFOX_0_8_RELEASE checkout
3. build from FIREBIRD_0_8_BRANCH checkout
It does not, however, work with the official build.

Proposed fix: build a fresh official build using the code from CVS, adding the
trademarked artwork. 
Shouldn't that work? Or is it perhaps a OS-version dependent issue? (does it
work on 10.3.x?)
Just a few thoughts...
I'm on Linux on ppc and there I can't verify the summary in comment #7. 
Installing Plugins doesn't work on a self-compiled version with the official
tar-ball.

For references, my identifier: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.6)
Gecko/20040210 Firefox/0.8
(In reply to comment #8)
Well - that is not the point of this bug. This is a MacOSX-only bug. 
If you are seeing sth. similar on Linux, file a seperate bug.
But IMHO there is no point contradicting #7 if you are not using OS X.
(In reply to comment #9)
> Well - that is not the point of this bug. This is a MacOSX-only bug. 

Oh, sorry, I didn't noticed the hardware-field above.

> If you are seeing sth. similar on Linux, file a seperate bug.

Will do, as I see there isn't any bug yet.  Thanks for advising :)
Severity: major → critical
Keywords: crash
(In reply to comment #10)
> (In reply to comment #9)
> > Well - that is not the point of this bug. This is a MacOSX-only bug. 
> 
> Oh, sorry, I didn't noticed the hardware-field above.
> 
> > If you are seeing sth. similar on Linux, file a seperate bug.
> 
> Will do, as I see there isn't any bug yet.  Thanks for advising :)

(In reply to comment #0)
> User-Agent:       
> Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.6) Gecko/20040206 Firefox/0.8
> 
> Firefox quits unexpectedly when trying to dowload and install an extension
> 
> Reproducible: Always
> Steps to Reproduce:
> 1.on extension page click to dowload/install an extension
> 2.dowload begins
> 3.application quits
> 
> Actual Results:  
> application quits and extension is not installed
> 
> Expected Results:  
> install extension like in firebird
> 
> crash log result :
> Component Manager: attempting to find symbols in a component alias of type
> (regR/carP/x!bt)
> ## Component Manager: attempting to find symbols in a component alias of type
> (regR/carP/x!bt)
> dyld: /Applications/Firefox.app/Contents/MacOS/firefox-bin Undefined symbols:
> /Applications/Firefox.app/Contents/MacOS/libxpcom.dylib undefined reference to
> _wcrtomb expected to be defined in /usr/lib/libSystem.B.dylib
> 
> Occurs every time on my two ibooks (the two of them with 10.2.6) with firefox
> (11/02/04). Worked fine with previous firebird (completely deleted) or mozilla...
> Otherwise firefox works relatively good...
(In reply to comment #12)
In latest nightly 20040214 when ibook wakes up bookmarks toolbar is now active.
I seems to work every time but I'm still checking to confirm.  

(In reply to comment #0)

> Component Manager: attempting to find symbols in a component alias of type
> (regR/carP/x!bt)
> ## Component Manager: attempting to find symbols in a component alias of type
> (regR/carP/x!bt)
> dyld: /Applications/Firefox.app/Contents/MacOS/firefox-bin Undefined symbols:
> /Applications/Firefox.app/Contents/MacOS/libxpcom.dylib undefined reference to
> _wcrtomb expected to be defined in /usr/lib/libSystem.B.dylib

Well, that is actually where the problem is.
When I replace "libxpcom.dylib" with the one from my build (same options as the
official, just built under 10.2.8), everything works fine. Supports my guess of
comment #7.
Hmm, this is obviously a dupe of bug 233574 (who's got some attention).

*** This bug has been marked as a duplicate of 233574 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: