overlaps between inline elements

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: David Feldman, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

On numerous pages it looks as though inline elements (bold text, links, italics,
etc.) aren't laid out correctly: The element is placed on top of part of the
surrounding text. Sometimes this just eliminates the space between it and the
rest of the text; at other times, parts of words are obscured by the inline
element sitting on top of them. You can see good examples of this through out
http://bugzilla.mozilla.org, as well as at http://macslash.org. It seems to be
worse at some font size settings. I don't think this is a Gecko problem because
it doesn't occur in Camino or Mozilla.

Reproducible: Always
Steps to Reproduce:
1. Visit one of the pages listed above.
2. If you don't see the problem, try adjusting the browser's font size setting.
Actual Results:  
See description above.

Expected Results:  
Inline elements should be laid out in line with the surrounding content.

Mac OS X v10.3.2
G4 Quicksilver 800MHz dual
1152 MB RAM

Comment 1

14 years ago
could you attach a screenshot please?
(Reporter)

Comment 2

14 years ago
Created attachment 143378 [details]
An example

The attached example is from the page http://www.bugzilla.org. Note how the
bold text is misaligned.

Comment 3

14 years ago
It does not reproduce.

Mac OS X 10.3.2
Use New Profile(All default setting)
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040210
Firefox/0.8
(Reporter)

Comment 4

14 years ago
Looks like it was a problem with my configuration. I deleted all Mozilla-related
files and it went away. Sorry to bother you. Thanks though: I've been seeing
this problem since the first release of Firebird.

Comment 5

14 years ago
When a problem occurs with the font currently used, a cause may be known by
showing the font name and a user customize file.

Comment 6

14 years ago
Marking WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 7

13 years ago
Created attachment 174851 [details]
Example of bold and italic text squished onto (and over) other text

Comment 8

13 years ago
Comment on attachment 174851 [details]
Example of bold and italic text squished onto (and over) other text

I've been experiencing the same problem (in-line elements overlapping text) --
but don't quite understand the fix. What Mozilla-related files should I be
looking for? or setting updates? to fix this?

ann dupuis
You need to log in before you can comment on or make changes to this bug.