acroread-plugin consumes 100% CPU making PDF reading slow (GTK2 problem?)

RESOLVED DUPLICATE of bug 198954

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 198954
14 years ago
14 years ago

People

(Reporter: Mikael Djurfeldt, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20040130 Firebird/0.7

I use the acroread plugin (nppdf.so) version 5.08.

When I read a PDF file through the browser, the plugin correctly starts
acroread. However, CPU consumption is continuously high---close to 100%.  This
does not occur if acroread is started from the command line.

This has bugged me and many others (people now and then post about it on various
lists; I suspect many just give up and switch to xpdf) for a long time (over a
year).  Some people have suggested it is due to a bug in GTK2, so I've tried to
recompile mozilla-firebird using GTK.  This makes the bug go away, supporting
the idea of a GTK2 problem.

Could you please isolate the problem and either make the GTK people fix it
upstream, or find a workaround?  Any hints about what I could do myself (patch;
other version of GTK2 etc) would be much appreciated.

Reproducible: Always
Steps to Reproduce:
1. Install the packages
ftp://ftp.nerim.net/debian-marillat/dists/stable/main/binary-i386/acroread-debian-files_0.0.5_all.deb
ftp://ftp.nerim.net/debian-marillat/dists/stable/main/binary-i386/acroread-plugin_5.08-woody0.1_i386.deb
ftp://ftp.nerim.net/debian-marillat/dists/stable/main/binary-i386/acroread-plugin_5.08-woody0.1_i386.deb
on a Debian system.
2. Read any PDF document in the browser.
3. Look at a CPU meter.

Actual Results:  
The CPU meter shows 100% usage.


Expected Results:  
The CPU meter should show moderate usage while not manipulating the acroread window.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 198954 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.