Closed Bug 234009 Opened 18 years ago Closed 17 years ago

Thread not detected when original message enters folder after the reply

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 181446

People

(Reporter: andreas.krueger, Assigned: mscott)

Details

User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040122 Debian/1.6-1

Whether or not a reply B to a message A is detected as being in one thread with A
depends on which message appeared in the particular mail folder first.

If A was there first, fine.  If B, the two messages are displayed in isolation.

Reproducible: Always
Steps to Reproduce:
1. I have a mail message A and an reply message B to A.
2. The two are displayed as two messages in one thread.
3. I move message B to a different folder.
4. I move message A to the same folder.

Actual Results:  
In the folder that now hosts the two messages, they are no longer
displayed as belonging to one thread.

Shutting down Thunderbird and restarting it does not help.

Now move them to still another (or the original) folder.
But this time move A first, than B.

Now they are again displayed as one thread.

Expected Results:  
Whether messages in a folder are displayed as a thread
should not depend on the relative sequence how the messages
got into the folder.

This is Mozilla Thunderbird 0.5 (20040209),
Debian package mozilla-thunderbird version 0.5-1.
.
Blocks: 236849

*** This bug has been marked as a duplicate of 181446 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
No longer blocks: 236849
You need to log in before you can comment on or make changes to this bug.