The default bug view has changed. See this FAQ.

[FIXr]printing of fieldset that spans multiple pages fails

RESOLVED FIXED in mozilla1.7beta

Status

()

Core
Printing: Output
P1
normal
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Dawid Loubser, Assigned: bz)

Tracking

Trunk
mozilla1.7beta
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5.1) Gecko/20031120

My page contains a fieldset (with legend) within a form. This fieldset contains a rather lengthy table 
inside it, cause the fieldset to wrap across multiple pages when printing the document. Printing results 
in an entirely blank page (no other part of the page prints). When I remove the content of the fieldset 
bit by bit, printing is successful as soon as the fieldset does not wrap across multiple pages.

Reproducible: Always
Steps to Reproduce:
1. Make <fieldset> within a <form>
2. Add a lof of content in it (e.g. multi-row table)
3. Try to print, simply a blank page results.
Actual Results:  
Blank page, not even the other content (Headers/Paragraphs) outside of the <fieldset> prints.

Expected Results:  
Fieldset element should have been broken up across pages, like tables do.
The basic problem is that nsCSSFrameConstructor::CreateContinuingFrame doesn't
know how to handle fieldset frames.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: MacOS X → All
Hardware: Macintosh → All
Created attachment 141243 [details] [diff] [review]
This seems to fix things for me.
Attachment #141243 - Flags: superreview?(dbaron)
Attachment #141243 - Flags: review?(dbaron)
Created attachment 141245 [details]
Testcase I used
Attachment #141243 - Flags: superreview?(dbaron)
Attachment #141243 - Flags: superreview+
Attachment #141243 - Flags: review?(dbaron)
Attachment #141243 - Flags: review+
Assignee: core.printing → bzbarsky
Priority: -- → P1
Summary: printing of fieldset that spans multiple pages fails → [FIXr]printing of fieldset that spans multiple pages fails
Target Milestone: --- → mozilla1.7beta

Comment 4

13 years ago
*** Bug 234643 has been marked as a duplicate of this bug. ***
Fix checked in for 1.7b
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.