Unable to re-save a deleted password

RESOLVED INVALID

Status

SeaMonkey
Passwords & Permissions
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Phil Stracchino, Assigned: dveditz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

I had Mozilla memorize my login password for LiveJournal.com.  Later on, since
Mozilla kept asking me if I wanted it memorized *again* every time I posted a
comment, I told Mozilla "Never for this site", because I couldn't find any other
way to stop it repeatedly asking.
Recently, I accidentally deleted my LiveJournal password from the saved
passwords list.  Now, despite removing livejournal.com from the Passwords Never
Saved list, I cannot get Mozilla to relearn my LiveJournal password.

Reproducible: Always
Steps to Reproduce:
1. Have Mozilla memorize a password.
2. Tell Mozilla never to memorize passwords for that site.
3. Delete the saved password.
4. Delete the site from the "Passwords Never Saved" list.
5. Attempt to re-memorize the password.

Actual Results:  
Mozilla never offers to re-memorize this password.

Expected Results:  
Once I removed livejournal.com from the Passwords Never Saved list, Mozilla
should have begun prompting me to save my LiveJournal password again.

Comment 1

14 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7a) Gecko/20040203

For testing, I created a new profile, and logged in at heise.de, and told
Passwort Manager: Never for this site.
Closed Mozilla, reopend, logged in, and didn´t see password manager.
Retried, no Password Manager seen.
Opened Tools->Password Manager, deleted heise.de, closed and started Mozilla,
and got asked again. Told to remember, emtered password, waited to be logged-in,
then closed Mozilla and DUN, reopened Mozilla, opened heise.de, for log in got
asked for Password, and P.M. filled in password and username, and log-in succeeded.
(Reporter)

Comment 2

14 years ago
I'm now unable to reproduce this myself, after it being solidly reproducible for
a week.  My only theory is that something to do with the challenge-response
login feature that LiveJournal recently implemented caused Mozilla to fail to
re-memorize the login.  I don't have any explanation for why it's now working
again, unless they found that problem independently and fixed it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.