After ending firefox process in task manager, download manager doesnt appear when new window is opened and download started

RESOLVED INVALID

Status

()

Toolkit
Downloads API
RESOLVED INVALID
14 years ago
10 years ago

People

(Reporter: Colin Soucie, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

I had a lot of firefox windows open (8-10) and I decided to kill the process
instead of closing each of them individually.  A few minutes later I wanted to
download a file.  After I choose the destination of the file and click save, the
window disappears... no download manager.  The file downloads, and the system
tray popup appears, but I never see the download manager and it doesn't appear
on my taskbar.  Tried restarting firefox, but still the window doesnt appear
anywhere.  Restarted Win2k and problem was gone.

Reproducible: Sometimes
Steps to Reproduce:
1.Open task manager
2.End Firefox process
3.Open new window, and download a file

Actual Results:  
It works fine now that I restarted.

Expected Results:  
It should have brought up the download manager so I could monitor my download.

Running Win2k SP4 on an Athlon XP 2000+ 512mb ram.  It would be nice to be able
to disable the download manager and use the old method, which I have always
preferred over managers.  Also, another idea would be to run the download
manager in a separate process so that in case Firefox crashes, your download is
still going.

Comment 1

14 years ago
The download manager will not open for files that take less than 5 seconds to
download. It'll just pop up that notification thing.

Could this be the cause of what you're seeing? I'm going to assume it is, and
mark this bug as INVALID because I can't reproduce this at all for large files.

If you are still having this problem with large files that take longer than a
few seconds to download, please re-open this bug, because in this case, if you
have the preference set, the download manager should show.

RE your suggests at the end. The old style download system is gone, and not
going to be re-implemented. The download manager is always also going to be in
firefox.exe, having a separate process isn't feasible right now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
QA Contact: aebrahim
Resolution: --- → INVALID
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.