Download biff notification should use native widget in Windows XP

RESOLVED WONTFIX

Status

()

Toolkit
Downloads API
--
enhancement
RESOLVED WONTFIX
15 years ago
10 years ago

People

(Reporter: Greg Campbell, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040210 Firebird/0.8.0+

Windows XP has a native biff notification widget: an icon in the system tray
with a cartoon speaking box containing the text. This would look more "natural"
in the OS than the current biff.

The icon probably should be the download manager icon (folder with an arrow),
rather than the application icon (that seems clearer to me, at least).

Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

15 years ago
Created attachment 141273 [details]
native XP biff

Example of XP biff notification
(Reporter)

Comment 2

15 years ago
From reading http://forums.mozillazine.org/viewtopic.php?t=51799 it seems like a
download manager systray icon could serve as the minimised state for the
download manager window. This removes taskbar clutter. Hover and it gives brief
download info; double-click and it shows the whole manager windows. When a
download finishes, the native biff pops up.

Of course, this behavior should possible be controllable by (hidden?) prefs
since people always bitch when the download manager does something they don't like.

Comment 3

15 years ago
I'm going to mark this as WONTFIX for the following reasons:

1) Firefox is a cross platform browser, and we want to give people as consistent
a user experience as possible across all platforms.
2) The Windows native biff notification is used primarily when some sort of
maintenance action has occured, or some sort prompt is required where the user
has not directly asked for any action to take place (like Windows updates). For
stuff that the user has directly initiated, this is better handled within the
application itself.
3) Programatically speaking, this may be a pain to implement, more so than is
worth the hassle.
4) The current method looks as if its part of Firefox. If we pop up a biff,
there is no immediate pictoral cue that this is a Firefox notification. It could
be confusing.

In related to adding a method by which the user can select either method, I
don't think this will get implemented because one of Firefox's design goals is
to minimise code size, and I think that most people would agree that duplicating
ways of doing the same thing goes against this goal.

Marking this WONTFIX is one of those calls that is borderline. In light of that,
please note that my opinion is not the be all and end all of everything, and
although I'm marking this WONTFIXED, this issue is still very much open for
discussion if you really disagree.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
QA Contact: aebrahim
Resolution: --- → WONTFIX
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.