Fixfox not following rfc2616: max-age header should override expires

VERIFIED DUPLICATE of bug 203271

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 203271
15 years ago
14 years ago

People

(Reporter: MG, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

From the RFC:

 If a response includes both an Expires header and a max-age directive, the
max-age directive overrides the Expires header, even if the Expires header is
more restrictive.

Reproducible: Always
Steps to Reproduce:
1.  Create a page with headers:
In Java my jsp code looks like:

    response.setHeader("Cache-Control","max-age=43200"); //HTTP 1.1
    response.addHeader("Cache-Control", "public");
    response.setHeader("Expires", "Thu, 01 Jan 1970 00:00:00 GMT");
    response.setHeader("Pragma", "");

Now open your browser, clear your cache.

Use tcptrace to sit in between browser and java server.

http://www.pocketsoap.com/tcpTrace

browse to tcp trace listening port with jsp page.

Note the headers.  You should see a GET from the browser and a RESPONSE from the
jsp server.

Now clear the tcptrace output, and then refresh the jsp page in your browser.

You will see another GET for this request.  The proper behavior is to pull it
from the cache.

I then tried exactly above but set the expires header to blank.  The browser
behaves correctly there is no get.  






2.
3.

Actual Results:  
File was requested from app server.

Expected Results:  
File should have been pulled from browser cache.

Comment 1

15 years ago
I think this is a duplicate of Bug 203271.
(Reporter)

Comment 2

15 years ago
Yeah you are right.  Is it just me or is the bugzilla search a piece of ****.

*** This bug has been marked as a duplicate of 203271 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

14 years ago
V/dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.