should be able to 'copy link location' on bookmarks

RESOLVED INVALID

Status

()

--
enhancement
RESOLVED INVALID
15 years ago
12 years ago

People

(Reporter: jmd, Assigned: p_ch)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
I think "Copy Link Location" should be added to the bookmark item context menu.
At least with my usage, this is the most common thing I right-click a bookmark for.

Presently, you either have to load the bookmark, then copy the text in the URL
bar, or open the (slow to load) properties dialog, select the text inside, copy
it to the clipboard, and then close the dialog.

One-click access in the context menu would be very helpful when I'm sharing URLs
via IRC/IM.

Setting to UNCO. If someone agrees they can NEW it.
"Copy" works for me in FF 0.8
(Reporter)

Comment 2

15 years ago
Perhaps it's an issue of not making it to the X primary selection than, if
"Copy" is meant to be more than intra-application CCP. To clarify, copying the
link should then allow you to middle-click in an X application, like Xterm, to
paste the URL.

Updated

15 years ago
OS: Linux → All
Hardware: PC → All
this one is odd, I can have right-click paste work, but it doesn't let me do
middlemouse pasting, that retains something different.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
I thought this used to be in Firefox, though, and was removed when the RSS stuff
was added.  I miss it too..

Comment 5

13 years ago
According to http://www.freedesktop.org/wiki/Standards_2fClipboardsWiki ,
explicity copying a item should copy it to the CLIPBOARD and not PRIMARY, and
middle mouse paste should always paste the PRIMARY, not the CLIPBOARD. So this
is INVALID.

That's for Linux; on Windows you can just use Copy to copy the item to the
clipboard.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.