Recurrence exception events being deleted when event updated

RESOLVED DUPLICATE of bug 231765

Status

--
critical
RESOLVED DUPLICATE of bug 231765
15 years ago
13 years ago

People

(Reporter: bill, Assigned: mostafah)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.6) Gecko/20040113

Here is the specific, first I have an event that occurs M-F, for about 9 months
(putting my daughters school schedule into the calendar).  There are many
exception days (holidays, teacher work days) spread throughout the year.  There
were several problems noted when I attempted this.  

First, there seems to be a finite number of exceptions allowed, somewhere
between 25-35, not sure exactly.  Seems to take all the input, but when you
click OK, the last few events are deleted.

Second, if you modify anything else in the event (even just opening it and
saving) all but 5 of the exceptions are deleted, and a strange exception from
1969 is added(12/31/69).  This one is easy to recreate, see steps to recreate.

I am running on NT SP 6a, with latest mozilla stable build and latest calendar.
 Calendars are being stored remotely, not locally (apache mod_dav).

Reproducible: Always
Steps to Reproduce:
1.ust create an event that spans at least a month or two, recurs daily, enter 15
exception days, save event
2.all looks well
3.then edit event, click on recurrence tab (no need to do anything else), click
OK to save, and event is now missing many of the exceptions and contains the
mysterious 12/31/69.

Actual Results:  
event is now missing many of the exceptions and contains the mysterious 12/31/69.

Expected Results:  
Should not have changed the event at all

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 231765 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.