Setting Thunderbird to Default Newsreader doesn't update news protocol handler entries in registry

RESOLVED WONTFIX

Status

Thunderbird
Preferences
RESOLVED WONTFIX
14 years ago
9 years ago

People

(Reporter: Eric Bus, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

I try to set Thunderbird as the default news reader for my computer. I select
the checkbox for the option and press OK. But, when clicking on nntp-links from
FireFox it reports that NNTP isn't a registered protocol. When I return to the
configuration screen, the option is still checked. I tried to disable the option
(uncheck it and pressing OK), but when I return to the configuration-screen, the
option is back on. So I can't disable it.

Reproducible: Always
Steps to Reproduce:
1. Go to preferences
2. If the box for Default newsreader is checked, uncheck it
3. Press OK
4. Return to the preferences and notice it is still checked

Actual Results:  
The checkbox remained checked, although I requested it to be turned off.

Expected Results:  
It should have cleared the box.

Comment 1

14 years ago
Eric Bus: you are correct that setting TB (or Moz) as the default newsreader 
does not correctly update the system settings for nntp, news and snews.  This is 
the same basic problem as bug 202497 (for mail).

However, I am unable to reproduce the symptom of being unable to uncheck the 
"default newsreader" box in Thunderbird's options page.  Are you still 
experiencing this issue with TB0.7?
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> However, I am unable to reproduce the symptom of being unable to uncheck the 
> "default newsreader" box in Thunderbird's options page.  Are you still 
> experiencing this issue with TB0.7?

I've just checked and the problem is no longer there. I can check and uncheck
both boxes and they stay that way when I return.

Comment 3

14 years ago
xref Seamonkey bug 121369.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → Windows 2000
Summary: Setting Thunderbird to Default Newsreader doesn't work → Setting Thunderbird to Default Newsreader doesn't update news protocol handler entries in registry

Comment 4

13 years ago
*** Bug 271857 has been marked as a duplicate of this bug. ***
QA Contact: preferences

Updated

10 years ago
Assignee: mscott → nobody
We now no longer support unsetting default newsreader/mail/etc options. To do this you have to set a different application to be default. Setting as default newsreader works for me, so this is a wontfix/works for me resolution.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.