XML Parsing Error on Startup

VERIFIED FIXED

Status

()

Firefox
Installer
--
blocker
VERIFIED FIXED
14 years ago
12 years ago

People

(Reporter: Travis Chase, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla Firefox 0.8 02/13/04 nightly

XML Parsing Error: Undefined Entity

Location: chrome://navigator/content/navigator.xul
Line Number 46 Column 1:

<window id="main-window"


Reproducible: Always
Steps to Reproduce:
1. Download the firefoxsetup.exe of 13/02/04
2. Start up Fire fox and the window pops up
3.

Comment 1

14 years ago
I have seen this as well.  It does not appear to occur with zipped builds from
the same date.

Comment 2

14 years ago
I've also seen this.  And another report at
http://forums.mozillazine.org/viewtopic.php?t=52927

I only have the problem with the installer.  The zipped build is working as
expected.  

Comment 3

14 years ago
->Installer
Assignee: firefox → bugs
Component: General → Installer
QA Contact: bugzilla

Comment 4

14 years ago
Getting this error on .8 official zip, Win98SE, Toshiba Satellite 2805-S402
laptop. On the laptop, I dual boot with winXP and have firefox & profile
installed on a shared drive. Firefox runs just fine when using XP.

I put the same zip build on a desktop computer running 98Se and firefox works
fine on it.  However on the desktop, I didn't run the profile manager first to
setup a special profile name or location.  Instead, I just ran Firefox and let
it create the default user profile in the default location.

Comment 5

14 years ago
*** Bug 234462 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
Setting severity to blocker. Can't do testing if you can't start the browser.
Severity: critical → blocker

Comment 7

14 years ago
Mmmmm, not quite, actually, the zipped build fromm feb/15 works...
I guess the installer is built from the same files used for the zip distro,
maybe the bug is in the installer (not installing something or installing a
corrupt file) and not in the browser itself...

Comment 8

14 years ago
The installer is not copying over the default prefs file, firefox.js (presumably
due to the name change) so the wrong chrome file is being loaded. I'd guess the
problem is here (though I'm not building the installer so I don't know for certain):

http://lxr.mozilla.org/mozilla/source/browser/installer/windows/packages-static#185

Comment 9

14 years ago
*** Bug 234569 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Keywords: regression

Comment 10

14 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Status: RESOLVED → VERIFIED

Updated

12 years ago
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.