_quote is unnecessary and misleading, since the meaning of the "css_class" and "url" is clear enough from the context, and since those filters escape, not quote. These filters should be named css_class and url just as the TT HTML escaping filter is named html.
Its different to the TT url filter, though....
TT's filter is "uri", though, not "url".
This is backend code, and is here for years. I don't see any harm keeping current names as such. Note that url_quote will go away in favor of the internal FILTER uri, see bug 398701, so this part is WONTFIX. mkanat has to explain to me how such a minor thing can have a priority of P2.
Priority: P2 → --
Summary: remove _quote from css_class_quote and url_quote → remove _quote from css_class_quote
Whiteboard: [Good Intro Bug] → [good first bug][lang=perl]
i agree that there's no real gain in resolving this ancient bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.