Graphic corruption in Firefox/Thunderbird chrome (buttons) when repainting

RESOLVED DUPLICATE of bug 224279

Status

()

defect
RESOLVED DUPLICATE of bug 224279
16 years ago
13 years ago

People

(Reporter: pkasting, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

16 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

The buttons and throbber of both Firefox and Thunderbird exhibit graphical
corruption when repainting on my machine.  When starting either app or resizing
their windows, the icons for the buttons and throbber have the upper-left corner
of the window (that is, an upper-left-corner line and most of the letters "Fil"
from the File menu) underlaid underneath their graphics.  This is of course more
noticeable for buttons with large transparent areas such as greyed-out buttons
(like "forward" when you first launch the browser), but it happens on all of
them.  On mousing over the buttons, the corruption changes: when I mouseover a
button, the corruption either completely or mostly vanishes (sometimes all or
part of the upper-left-corner lines remain on the button).  If I then mouse
directly to another active button to the left (say, moving from "Reply All" to
"Reply" in Thunderbird), then part of the icon for the button I've just moves to
appears underneath the icon for the button I've just moved from.  If I instead
move to the right, or off the button area completely, or onto a greyed-out
button or a spacer, the corruption usually vanishes completely.  Sometimes when
doing this series of steps several times I note what look like xor-painting
problems: for example, that upper-left corner image I keep mentioning is
actually made of a light line adjacent to a dark line, and I'll see one of those
two lines corrupting the image when my mouse is over it and the other corrupting
it when my mouse is not.
Other actions causing repaints, like minimizing and restoring or dragging
another window over the button area, cause seemingly random graphical corruption
as well; dragging a window over the buttons is especially interesting since the
corruption seems to depend on exactly what was obscured and newly uncovered when
each repaint happened.  If I drag quickly enough to get the whole area in one
repaint all the buttons have the same image underlying them, generally whatever
was in the upper left of the area that got uncovered (again, typically the File
menu; sometimes the Back button).  If I drag more slowly each successively
repainted area has a different image under it.

Reproducible: Always
Steps to Reproduce:
1. Launch Firefox or Thunderbird, using default theme.
2. Observe buttons/throbber, look for signs of graphical corruption underneath
icons.
3. Try mousing over and off of the buttons in different ways to try and
reproduce different types of graphical corruption.
4. Try minimizing and restoring, or hiding the window behind another, or some
other action that will force a repaint.

Actual Results:  
Various graphical corruption under the icons for the buttons and throbber.

Expected Results:  
Buttons displayed properly after all repaint events.

I am using the default theme for Firebird and Thunderbird, and haven't installed
any additional themes.  When migrating from Mozilla [Seamonkey] I copied most of
my Mozilla profile to my Phoenix and Thunderbird profile directories, making
sure to edit the absolute paths in the files as necessary.  I tried deleting the
chrome/ directory in each of the profile directories; this seems to have no effect.

This problem reproduces whether the buttons are small or large icons and whether
or not they have text under them (the text never exhibits corruption).  The
problem does not reproduce with Mozilla [Seamonkey] 1.6 on the same machine,
using the Modern theme.

System configuration:
Win2K SP4
NVidia Riva TNT2 Model 64, DirectX 9, DirectX display drivers say they are
version 6.14.10.5216
Firefox 0.8
Thunderbird 0.5
Reporter

Comment 1

16 years ago
This image demonstrates the most common corruption of the icons: showing the
upper-left corner of the browser window under each button.  You can see the
upper-left-corner image (a leftmost and topmost line) and the letters "Fil"
underneath all the buttons (some buttons' icons obscure the corruption more
than others.)
Reporter

Comment 2

16 years ago
The corruption doesn't just affect icons on buttons; this attachment shows
problems with the folder icons in Thunderbird as well.	Harder to see these,
but look for example at the right edge of the "Junk" folder icon.  This
corruption goes away if I click on the "Junk" floder name and returns as soon
as I click anywhere else so that selection loses focus or is deselected.

Note also the button icon corruption: here, for example, you can see part of
the "Reply" button image underneath the "Reply All" button's image.

Comment 3

16 years ago
I'm not sure if there is an existing bug filed for this but for reference this
has been reported by several people on the MozillaZine forums. It seems to only
affect TNT cards with fairly recent drivers installed. Most people report it
disappears if you lower your hardware acceleration slider by one notch or revert
to older drivers.
Reporter

Comment 4

16 years ago
I can verify that changing the TNT2's hardware acceleration from "Full" to one
notch less than full ("Disable cursor and bitmap accelerations") fixes the
problem, so that's a good workaround.  It would be nice to know if this is still
going to be considered a "bug" in Mozilla to be worked around/patched to avoid,
or if this is INVALID/WONTFIX or something and needs to be filed with NVidia. 
(Well, it probably needs to be filed with NVidia regardless.)

*** This bug has been marked as a duplicate of 224279 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.