Mozilla 1.6 & Firefox0.8 bad display

RESOLVED INVALID

Status

()

Core
Layout
--
major
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Lancelot Pecquet, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(6 attachments)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

My home page http://www-rocq.inria.fr/~pecquet was correctly rendered by 
Mozilla 1.4 and Mozilla 1.5, according to the W3C standards (my pages & CSS 
validate thouroughly). The latest version of Mozilla (1.6) and the current 
version of Firefox (0.8) have the same problem: the central block is 
translated inside the right block. Microsoft IE displayed was bad (5pixels shift
for whatever reason...). Apple Safari also had a display problem... Please, remain
W3C compliant!

Reproducible: Always
Steps to Reproduce:
Type  http://www-rocq.inria.fr/~pecquet in the URL bar of Mozilla 1.6 or 
Firefox 0.8

Actual Results:  
The central block collides with right block


Expected Results:  
Type http://www-rocq.inria.fr/~pecquet in the URL bar of Mozilla 1.4 or 1.5
and see.
(Reporter)

Comment 1

14 years ago
Created attachment 141386 [details]
Display with Mozilla 1.4 and 1.5

Tested e.g. with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/2003100
(Reporter)

Comment 2

14 years ago
Created attachment 141387 [details]
Display with Mozilla 1.6

Screenshot from Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113
(Reporter)

Comment 3

14 years ago
Created attachment 141388 [details]
Display with Firefox 0.8

Screenshot from Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207
Firefox/0.8
(In reply to comment #0)
> Mozilla 1.4 and Mozilla 1.5, according to the W3C standards (my pages & CSS 
> validate thouroughly). The latest version of Mozilla (1.6) and the current 

Just because the pages validate doesn't mean the correct layout is what you
think it is.
Mozilla's display is closer to correct than it used to be, but it's still not
perfect.  In particular:

The margin box of an element in the normal flow that establishes a new block
formatting context (such as a table, or element with 'overflow' other than
'visible') must not overlap any floats in the same block formatting context as
the element itself. If necessary, implementations should clear the said element
by placing it below any preceding floats, but may place it adjacent to such
floats if there is sufficient space.
Created attachment 141391 [details]
Minimal-ish testcase

So I assume for a new block formatting context the margin should be measured
from the right edge of the preceding float (if any) like this?
Created attachment 141393 [details]
Testcase for the overlap
(Reporter)

Comment 8

14 years ago
Created attachment 141897 [details]
Display compatible with 1.6 but incompatible with other versions

Well thanks for the piece of advice Boris: the result is indeed correct under
Moz1.6 by setting margin-left: 5px; (counting from the previous block rather
than
from the "real" left margin). However, the result is badly displayed by former
versions (cf. attachment). What can I do to have a fully compliant xhtml/css
that 
suits all versions of Mozilla? Thanks. L.
(Reporter)

Comment 9

14 years ago
David,

Thanks explaining: I'm not sure I fully understand how to bypass the constraint
you mentioned. Can you help?

Thanks,

L.
(Reporter)

Comment 10

14 years ago
Well... I just removed the overflow:hidden stuff. It solves the problem if
the user doesn't increase too much the font size. Thanks to all for your help.

Comment 11

13 years ago
Resolving INVALID. This wasn't a bug in Mozilla.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 12

13 years ago
Oops, really resolving as INVALID now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.