mail client never sends syn packet to establish connection

RESOLVED INVALID

Status

MailNews Core
Backend
--
critical
RESOLVED INVALID
14 years ago
9 years ago

People

(Reporter: Jaco Kroon, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040214

Recently I started getting this problem where mozilla would not actually send
the syn packet required.  I started noticing this after rebooting to Windows
2000 which still had an older version (1.3.1).  Rebooted back to linux (1.6) and
suddenly it stopped working.

Reproducible: Always
Steps to Reproduce:
1.  Open mozilla -mail
2.  Request receiving of mail.
3.  Almost immediately receive timeout errors.

Actual Results:  
Almost immediately receive timeout errors.

Expected Results:  
Should've connected to my mail server as usual and retrieved my mail.

I've been running ethereal in parrallel to this with a filter of (dst port 110
|| src port 110) and it came up empty handed, unless I actually telnet to the
mail server on port 110, then I get the expected results in ethereal.

I've also seen this on one of our lecturers (Netscape 4.? as well as 7.?)
machines and neither me nor the rest of the techteam managed to fix this.

I have already re-emerged mozilla (using gentoo), it didn't solve the problem. 
I've updated the windows 2000 install to mozilla 1.6, I have rebooted the
machine as well.

The only thing that is actually shared between the two installs is the actual
Mail dir inside the profile directory.

Comment 1

14 years ago
Do you have any address entered for a SOCKS proxy
(Preferences/Advanced/Proxies)? Does sending a messages via SMTP work?
(Reporter)

Comment 2

14 years ago
Worked with that previously, I've just unset the proxy and it works now, thanks.
 My mistake.

I presume that is why I never picked up the SYN packets, they were sent to
another port entirely, and the proxy on the other end is presumably (as at
varsity) a http proxy, not socks.

Yes, mailing via smtp worked in any case.  The smtp server entered is the same
as the proxy (at least, I changed it to be the same host becaus it failed
otherwise) - might be due to the invalid proxy setting so mozilla attempted to
connect to the smtp using socks as well, instead of simply connecting directly.

btw, How does mozilla decide whether to use the proxy or connect directly?  Is
there, for example, any way to get mozilla to do the dns resolution and then
decide whether or not to use the proxy based on the IP address?  Or should I
just put "localhost, 127.0.0.1, *.lan, 192.168.0.*" into the exclude list?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 3

14 years ago
I only know about that POP/SOCKS symptom because it's nearly a FAQ.
Can't say anything about how the decision code works.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.