Closed Bug 234390 Opened 21 years ago Closed 21 years ago

Feature request: Some way to open a new window/tab with the same "back" stack

Categories

(Firefox :: General, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 18808

People

(Reporter: rakslice, Assigned: bugzilla)

Details

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

I would love some way to open a new window or tab with the same page open as was
open in the tab that was active before, and with the same stack of pages in the
Back list as was in the old tab's back list.

Why?  This behaviour is very handy.  Suppose I'm browsing along (say, through a
mailing list archive), and I decide that I want to open the page two steps back
in my Back list in a new tab, keeping the current one open so I can quickly flip
back and forth.  With the functionality I'm suggesting, doing this is as easy as
opening a new tab and then going back two pages.

This could be implemented as a preference toggle that would make the normal File
menu and context menu's "New Window" and "New Tab" options behave this way.  Or,
another menu item could be added to do this (something like "Duplicate Tab/Window").



Reproducible: Always
Steps to Reproduce:
1.
2.
3.
See also bug 112372, same bug for Seamonkey.
Oh, found an extention (Clone Window) that does this nicely for windows and tabs.

*** This bug has been marked as a duplicate of 18808 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.