'mozilla' hardcoded into application install paths

RESOLVED FIXED in mozilla1.7beta

Status

SeaMonkey
Build Config
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: cls, Assigned: cls)

Tracking

Trunk
mozilla1.7beta

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

8.39 KB, patch
Brian Ryner (not reading)
: review+
Details | Diff | Splinter Review
(Assignee)

Description

14 years ago
When using 'make install' to install the franken-gecko apps, the apps overwrite
each other because the mozappdir contains a hardcoded mozilla name.  mozappdir
is where all of the components are installed.  As long as the apps share a
common build system, there needs to be a way (--enable-app-name ?) to specific
which app we are building for 'make install'.  Other things that would need to
be properly versioned are the includedir and the pkgconfig files.

Bug 228866 may have been caused by this problem.
(Assignee)

Comment 1

14 years ago
Created attachment 141626 [details] [diff] [review]
v0.8

Here's the preliminary patch which adds --with-moz-appname to configure.  This
lets us set the name which is used when packaging the build whether using 'make
install' or 'make -C xpinstall/packager'.  The one thing I don't like about
this patch is that you wind up with paths like, /usr/lib/firefox-1.7a .  The
application version number should probably be configurable as well but right
now MOZILLA_VERSION is tied into the locale version which shouldn't revert to
0.8a just because we're building firefox.
(Assignee)

Comment 2

14 years ago
Created attachment 142070 [details] [diff] [review]
v1.0

Took a different approach.  Rather that adding another configure option, just
base the appname & version off of the env variables which are required to build
each app.
Attachment #141626 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #142070 - Flags: review?(bryner)
Attachment #142070 - Flags: review?(bryner) → review+
(Assignee)

Comment 3

14 years ago
Patch has been checked in.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.7beta

Comment 4

14 years ago
(In reply to comment #3)
> Patch has been checked in.

how to set the env variables? I did a regular exports at the command line and I
get this
/usr/lib/@MOZ_APP_NAME@-@MOZ_APP_VERSION@# not the /usr/lib/firefox-0.8 as I
wanted it to be.

I did this before I did the make
export MOZ_APP_NAME=firefox
export MOZ_APP_VERSION=0.8
(Assignee)

Comment 5

14 years ago
You don't set them manually.  You apply the patch, run autoconf 2.13 in the
mozilla directory then build as normal.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.