UUencode'd attachment handled as text when inline-forward/edit as new

NEW
Unassigned

Status

MailNews Core
Composition
14 years ago
7 years ago

People

(Reporter: Mathieu Malaterre, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

I am suscribed to news://alt.binaries.fr.humour where people often send funny
pictures. Sometime I would like to forward those pictures as attachment to some
friends not susbscribe to this newsgroup. But mozilla fails to. I cliked 'save
as' on one of those mails, you'll find it here:
http://malat.free.fr/mozilla/PerteDePoids.eml

Or you might just want subscribe to this newsgroups. BTW it could be related to
the combine and decode problem.

Reproducible: Always
Steps to Reproduce:
1. Subscribe to a newsgroup where people send binaries
(news://alt.binaries.fr.humour)
2. Select one that has a picture as attachment.
3. Click 'Forward' or 'Edit As New'


Actual Results:  
The message forwarded look like this:



-------- Original Message --------
Subject: Perte de poids
Date: Sun, 15 Feb 2004 19:51:00 +0100
From: PHILIPPE.WEISS13 <PHILIPPE.WEISS13@wanadoo.fr>
Organization: Wanadoo, l'internet avec France Telecom
Newsgroups: alt.binaries.fr.humour



begin 666 Perte de poids.JPG
M_]C_X `02D9)1@`!``$`E@"6``#__@`?3$5!1"!496-H;F]L;V=I97,@26YC
M+B!6,2XP,0#_VP"$``@%!@<&!0@'!@<)" @)#!0-# L+#!@1$@X4'1D>'AP9
M'!L@)"XG("(K(AL<*#8H*R\Q,S0S'R8X/#@R/"XR,S$!" D)# H,%PT-%S$A
<snip>

Expected Results:  
It should create a mail containing this text

-------- Original Message --------
Subject: Perte de poids
Date: Sun, 15 Feb 2004 19:51:00 +0100
From: PHILIPPE.WEISS13 <PHILIPPE.WEISS13@wanadoo.fr>
Organization: Wanadoo, l'internet avec France Telecom
Newsgroups: alt.binaries.fr.humour



and add as attachement the picture.

BTW I am able to save the picture with a double click, create a new message,
copy/paste text, and then create attachement from the file saved on my hard drive.

Comment 1

14 years ago
This is true.  Reproduced with 1.6 final and 1.8a2-0610, Win2K.  Probably true 
for all platforms.

The image in that mail has been "uuencoded" -- this is an older way to provide 
an attachment to a message. (MIME is preferred.)  In my testing, the forwarded 
message is not properly decoded by Mozilla, either; I'm not sure why.

Workaround (recommended!): instead of forwarding for a message like this, start 
a NEW message and then drag the image from the displayed message's attachment 
panel to the new message's attachment panel (not to the new message's body).  
This will properly attach the image, with the file name, as a MIME part.  (You 
can also drag the image directly from the message body, but you'll lose the 
filename.)

I'm not sure what the proper component is for this bug; probably not Front End, 
maybe Composition or Attachments or MIME or ...?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → Windows 2000
Summary: Attachement being lost when forward/edit as new → UUencode'd attachment handled as text when inline-forward/edit as new

Comment 2

14 years ago
Created attachment 150657 [details]
Reporter's message

Attaching the reporter's original file to this bug; Mathieu, you can take it
down off your website now...

Comment 3

14 years ago
Bug 61810 may be relevant; the forwarded/"as new" message does get a header:
  MIME-Version: 1.0

However, I edited the mail file to remove that header from the 'Sent' message 
and the image still does not appear.

Comment 4

14 years ago
*** Bug 231929 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Comment 5

12 years ago
*** Bug 313666 has been marked as a duplicate of this bug. ***

Comment 6

12 years ago
From the dupe, attachment 201155 [details] is another sample message.  Reporter states that the attachment was originally generated by using   File|Send To...  from Microsoft Word -- but he didn't state which mail client was used to generate the message.  In my testing, TB doesn't use UUencoding to make an attachment.

Moving to Core.
Component: MailNews: Main Mail Window → MailNews: Composition
Product: Mozilla Application Suite → Core

Comment 7

12 years ago
*** Bug 339900 has been marked as a duplicate of this bug. ***

Updated

10 years ago
Assignee: mail → nobody
QA Contact: esther → composition
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Updated

7 years ago
Duplicate of this bug: 618426
You need to log in before you can comment on or make changes to this bug.