If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

bookmarks menu accesskeys conflict with selecting bookmarks by typing first letter

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
RESOLVED WONTFIX
14 years ago
11 years ago

People

(Reporter: Paul Pelzl, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

In general, bookmarks can be selected by opening the menu with Alt-B, then
hitting the first letter of the bookmark (or submenu) you wish to select. 
However, the accesskeys for [A]dd to Bookmarks, [M]anage Bookmarks, and [O]pen
in Tabs take precedence.  The user is unlikely to anticipate this behavior, and
may end up [M]anaging bookmarks instead of visiting [M]etaFilter.  (Accidentally
opening fifty bookmarks in tabs is an even more irritating outcome.)

I'd like to see these accesskeys removed.  No more than one press of an arrow
key is needed to access any of the three functions listed, so there is an
adequate replacement for the accesskeys.

Reproducible: Always
Steps to Reproduce:
1. Alt-B to open bookmarks menu
2. Hit M to open a bookmark beginning with letter M
Actual Results:  
bookmarks manager opens up

Expected Results:  
load up the URL for the bookmark beginning with letter M
accesskeys are not going to be removed from the menus.  There's no point in 
trying to argue that point, since its needed for accessibility reasons.

Marking WONTFIX, Pierre, if you have an objection to this, please reopen, but I 
can't think of any reason to support this functionality over accesskeys (I'm 
not sure about the ramifications for Section 508 compliance either, but I doubt 
this would agree with that)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

14 years ago
If the accesskeys cannot be removed, then perhaps the "select bookmark by typing
first letter" functionality should be disabled.  The user should not be exposed
to an unpredictable situation such as this.

Comment 3

14 years ago
Please re-open this bug.  The problem described by the original submitter is in
fact a problem, even if his requested solution is not acceptable.

The problem is that the access keys for the bookmarks menu options "Add to
bookmarks", "Manage bookmarks", and in bookmark folder submenus "Open in tabs"
(A, M, and O respectively) take exclusive priority over bookmark entries
beginning with the same letter.  This is an accessibility problem, equally as
much as if the access keys for the "Add to bookmarks" etc were removed.  Unlike
the original poster, I don't recommend removing those access keys, but I do
think that keyboard access to the bookmark entries is just as important as
keyboard access to the menu options.

I suggest that a better solution would be to make bookmark entries and menu
options equivalent for the purposes of using access keys.  In other words, if a
bookmark list contains Metafilter and Monster, then pressing M would cycle
between "Manage bookmarks", "Metafilter", and "Monster"; the user would press
Enter when the selection was on the item he desired.  Similarly, in a bookmark
folder submenu, pressing O should cycle the selection between all the entries in
that submenu beginning with O and the command "Open in Tabs".

Note that this is what IE does; the Favorites menu has two commands: Add to
Favorites and Organize Favorites.  Pressing A or O cycles between the command
and all the bookmark entries begining with A or O.

Please do not implement the suggestion to disable "select bookmark by typing
first letter".  Those of us who use the keyboard to navigate would sorely miss
this functionality.

Also, the OS for this bug should probably be "All".  The original reporter is
using Linux, but the problem is also apparant on Windows.  My build identifier
is below, but every version of Phoenix/Firebird/Firefox I have used has had this
problem.

Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b)
Gecko/20040406 Firefox/0.8.0+ (MozJF)
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks

Comment 5

11 years ago
Can this bug be reopened and made dependent on bug 306010 please?
You need to log in before you can comment on or make changes to this bug.