If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox 0.8 crashes when attempting to install new extensions. Installation of new extensions fails.

RESOLVED DUPLICATE of bug 233574

Status

()

Firefox
Build Config
--
critical
RESOLVED DUPLICATE of bug 233574
14 years ago
14 years ago

People

(Reporter: Seth, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040113

Firefox 0.8 crashes unexpectantly when attempting to download and install new
extensions from:
 MozDev.org's Extension Room - http://extensionroom.mozdev.org/
 
This crash causes the installation of new extensions to fail.

Firefox 0.8 still  crashes and fails to install new extensions even if the new
extensions have been already downloaded locally to the hard drive.

Reproducible: Always
Steps to Reproduce:
1. Choose a new extension to install either from Mozdev.org Extension Room
(http://extensionroom.mozdev.org/), or if the extension has already been
previously downloaded to the computer's desktop or into a folder locally on the
hard drive. 
2. Clicking the link that says, "Install for Firefox/Install for Firefox on Mac"
3. Or from Firefox's Menu Bar: 
1)Choose File, 
2) Scroll down to "Open File", 
3) Navigate to the folder on the hard drive where the extension was previously
downloaded, 4) Choose an extension, 
5) Click "Open" 

Actual Results:  
Firefox 0.8 begins the installation process, but will crash either immediately
or  before the installation progress bar finishes.

Expected Results:  
Firefox 0.8 should have successfully installed the new extension. Upon
successful installation Firefox 0.8 should be quit and then relaunched to fully
complete the installation.
This same procedure worked in Firebird 0.7, but for some unknown reason Firefox
0.8 crashes everytime and causes new extensions to never be installed.

Comment 1

14 years ago
Dupe of bug 233843?

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 233574 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.