Type 3 crash with "Go" menu, problems with text entry, and more

VERIFIED WORKSFORME

Status

P3
critical
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: stevesauer, Assigned: elig)

Tracking

Trunk
PowerPC
Other

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: needs to be split or duplicates found (2000-01-12))

(Reporter)

Description

19 years ago
Using newest version M12 Mozilla Build ID: 199912211. Running in Mac OS 9.

I am
using Mozilla for the first time tonight and here is a list of the bugs
I've
encountered.

#1. Cannot log into Hotmail. Clicking the "Sign In" button does
nothing.

#2. When entering text into this report, the window remains stationary
while you
type in text that is off the screen. This also occurred when typing in
a comment
to the www.imusic.com message board and the www.thecreatures.com
message board.
It appears this a problem with all postings. The window is now
scrolling wildly
as I am writing this. It appears that the browser has a lot of
problems with
large amounts of text. There are single spaces which appear to the
left of new
lines of text. Sometimes when you attempt to insert the cursor into
the middle
of a sentence the cursor jumps to another random place in the text
and the
window will scroll.

#3. Pop-up selection lists don't scroll often and
when they do, the top of the
pop-up menu is missing. www.macfixit.com (forums).

#4. When you submit a form, the "auto-fill" window comes up that tells you about
the auto-fill feature (I forgot your term for it). When you dismiss the window,
the browser ceases to work. You must close the main window and open a new one in
order to continue browsing. www.thecreatures.com (message board) and
www.macfixit.com (message board). Once you have dismissed the atuo-fill
notification and opened a new window and gone back to the page, it does not pop
up again when you post a message. However, it will come back when posting to
another site.

#5. Can't change themes. I even tried the documented trick of
opening another
main browser window.

#6. When you highlight text, the "copy"
command is unavailable from the Edit
menu. Copying working with the keyboard
command.

#7. When you drag the right side of the Panels window to try to hide
it, the
white space within the Panels window will come out over the right window
border
and overlap if you drag the window over too far to the left. I don't like
the
Panels window at all and I hope it can be completely disabled in the final
version.

#8. Some links do not show up as links. They show up as plain text
only. One
such instance occurs just after posting a message to a www.imusic.com
message
board. In the www.macfixit.com forums, there are links back to the
previous
forums you have been in at the top right of the page. These links show
up as
text not as links.

#9. The cursor will jump backwards in a line of text
at random when entering
text into a form. Sometimes you cannot enter spaces
between words; the window
will scroll up.

#10. When I had registered for
Bugzilla, I went to the link about "how to report
bugs" and then read the "most
often reported bugs list." Then I went to the "Go"
menu to try to go back to the
"Enter bug" page. Mozilla crashed with a type 3 error.

Comment 1

19 years ago
*** Bug 23455 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Severity: normal → critical
Whiteboard: needs to be split or duplicates found (2000-01-12)
I suspect many of these problems are duplicates.  However, the ones that aren't
are unlikely to be fixed unless somebody files them as separate bugs.

Updated

19 years ago
Assignee: nobody → elig
QA Contact: nobody → elig

Comment 3

19 years ago
elig, cleaning up the 'nobody' Browser-General.  This is a lot of possibel bugs
in one.  Can you tear apart this one whilst I move on to the others?  Thanks!
(Assignee)

Comment 4

19 years ago
stevesauer@hotmail.com, in the future, please be sure to submit separate bug
reports separately, with one issue per bug report. Mega-bugs like this one tend
to be closed out because they're too unwieldy to handle.

#1: hotmail. Sounds like a duplicate. Please feel free to check on a current
build and submit as a separate bug if not.

#2: Not sure if a bug exists for this. Will check.

#3: Pop-ups are still busted; this is probably a duplicate. Please feel free to
check on a current build and submit as a separate bug.

#4: This sounds obvious and annoying enough that I assume it must have been
reported. Please feel free to check on a current build and submit as a separate
bug.

#5: Themes not really implemented yet.

#6: 14026, I think.

#7: Sounds like a known sidebar problem. Not certain. Please feel free to check
on a current build and submit as a separate bug.

#8: I'm not seeing this. Please feel free to check on a current build and submit
as a separate bug.

#9: Please feel free to supply a reproducible test case using a current build,
and submit as a separate bug.

#10: Please feel free to supply a reproducible test case using a current build,
and submit as a separate bug.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 5

19 years ago
I'm going to resolve this all as WORKSFORME. I don't mean to be a jerk and do
appreciate your taking the time to provide the feedback.

(Unfortunately, just going through this one bug report would take a half-day,
most of the issues here are already known, and I'd be surprised if there's
anything new. If these were submitted as separate bug reports, it would be easy
to send them to the appropriate QA contacts who'd know whether open bugs existed
or not.)

Please feel free to get a nightly build, query for dupes, and write up individual
issues for ones that aren't already known.

---

#2 itself comprises a half-dozen or so issues, most of which I can't reproduce on
a current build. The space appearing as the first character is a known bug that
jfrancis is dealing with.
(Assignee)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Comment 6

19 years ago
Rubber-stamping as verified.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.