Current nightly zip (20040215) installs to "firefox" directory

RESOLVED WONTFIX

Status

()

Firefox
General
--
trivial
RESOLVED WONTFIX
14 years ago
14 years ago

People

(Reporter: Stephen Price, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040215 Firebird/0.8.0+

The Firefox 0.8 release installer/zip and the current nightly installer install
to a directory called "Mozilla Firefox" by default. The current nightly build
zip installs to a directory called "firefox". Since it seems the former is the
standard directory, the zip should be changed to match it.

Reproducible: Always
Steps to Reproduce:
I don't really care, but I don't think this is worth the time to change it
Severity: normal → trivial
QA Contact: mconnor

Comment 2

14 years ago
I think you will find this is something that matters to a lot of people. It is
completely inconsistent that directories should keep using different names and
name formats the whole time, and it should be rectified.

I frequently have up to 10 different builds unzipped so I can find exactly when
regressions started - having to muck about with different folder names and
locations really makes my life difficult when I need to automate stuff with
sortcuts to builds, profiles, directories etc. It IS NOT a massive fix, and I
think it is worth just getting some stability.

Mozillazine has started a discussion of this at
http://forums.mozillazine.org/viewtopic.php?t=54676

I suggest it is worth reading.
(Reporter)

Comment 3

14 years ago
Yes, this is fairly trivial, but wouldn't it be trivial to fix as well?
Inconsistency hurts acceptance.

Comment 4

14 years ago
(In reply to comment #3)
> Yes, this is fairly trivial, but wouldn't it be trivial to fix as well?
> Inconsistency hurts acceptance.

No, because those who use the zip builds would have to change directories again,
and go through changing related paths and shortcuts and perhaps windows registry
entries. At this point firefox is standard and it's best not to change it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.